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Foreword

General Information

The information in this manual has been reviewed for accuracy. However, no responsibility is
assumed for inaccuracies. Motorola reserves the right to make changes to any products
discussed herein. The information in this document is subject to change without notice.
Motorola assumes no liability for hardware or software damage or loss of data because of
errors or omissions in this manual. Motorola does not assume any liability arising from the
application or use of any products or circuits described herein. Neither does Motorola convey
any license under its patents or right of others.

Refer questions concerning the contents of this manual or requests for related circuit board
information to the following location:

Motorola, Inc.
Paging Systems Group
Multimedia Publications Department
5401 North Beach St., MS E230-A
Fort Worth, TX 76137-2794

or telephone: (817) 245-4222

To access on-line electronic information (BBS) for service notices and the latest software
releases, call the Paging One-Call-Support Center. To request additional manuals or parts,
please contact the Motorola Americas Parts Division:

telephone: (800) 422-4210
facsimile: (847) 538-8198

To request a part number, contact the Parts Identification Group:

telephone: (847) 538-0021

For Motorola Infrastructure and communicator test equipment, contact the Motorola Test
Equipment Center:

telephone: (800) 505-837
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Global Service Organization
Motorola provides Infrastructure and communicator technical support through authorized or
company-owned Service Centers. Motorola also provides service for communicators on a
contract basis. For contract service information, please contact your local Motorola
representative or the Paging One-Call-Support Center:

Motorola, Inc.
Paging One-Call-Support Center
5401 North Beach St., MS E112
Fort Worth, TX 76137-2794

telephone: (800) 520-7243 or
(817) 245-4663

facsimile: (817) 245-2141
electronic mail: FOCSC1@mot.com (to have Technical Support contact you)

Service Training
Motorola, through its Advanced Messaging Technical Training Group in Fort Worth, Texas,
offers courses on communicators, messaging switches, transmitters, and receivers. These
courses are taught on the site or at a customer’s location.

Students learn to install, configure, and maintain Motorola messaging systems. The
classrooms at Motorola are equipped to ensure hands-on experience in practical lab exercises.

Training courses range from a basic introduction to communicators and messaging systems to
customized classes on specific systems and large system applications.

To obtain a course catalog or scheduling information, please call (817) 245-2184 or
(800) 724-3588 and ask for the training coordinator.
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Computer Software Copyrights
The Motorola products described in this manual might include copyrighted Motorola
computer software stored in semiconductor memories and other media. Laws in the United
States and other countries preserve for Motorola certain exclusive rights for copyrighted
computer programs, including the exclusive right to copy or reproduce in any form the
copyrighted computer software.

Accordingly, any copyrighted Motorola computer software contained in the Motorola
products described in this manual cannot be copied or reproduced in any manner without the
express written permission of Motorola.

Furthermore, the purchase of Motorola products does not grant, either directly or by
implication, estoppel, or otherwise, any license under the copyrights, patents or patent
applications of Motorola, except for the normal, nonexclusive, royalty-free license to use that
arises by operation of law in the sale of a product.

Trademarks
Motorola, SuperStream, and FLEX are trademarks of Motorola, Inc. Other trademarks are
noted as such throughout this document.

Antares and Dialogic are trademarks of Dialogic Corporation. HP, Hewlett Packard,
OpenView, and LaserJet are registered trademarks of Hewlett-Packard Company. Intel is a
registered trademark, and 80286 and Pentium are trademarks of Intel Corporation. UnixWare
is a registered trademark of Novell, Inc. Solaris, Sun, Java and Solaris are registered
trademarks of Sun Microsystems, Inc. Static Stop is a registered trademark of Barco Chemical
Products. Informix is a registered trademark of Informix Software, Inc. SPARC is a trademark
of SPARC International. WMtp is a trademark of Glenayre. X Window System is a trademark
of the Massachusetts Institute of Technology.

Trademarks contained herein are the acknowledged property of their respective owners.
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Important Safety Information

The installation, maintenance, and/or operation of this equipment may present potentially
unsafe conditions, including, but not limited to, electrical shock, improper voltage to
components, and improper operation that can cause personal injury, death or damage to
property.

Read Instructions: Read all the safety instructions before operating the equipment. Retain
these safety instructions for future reference. Specialized procedures and instructions are
required and must be followed. Also, all applicable safety procedures, such as Occupational,
Safety, and Health Administration (OSHA) requirements, National Electric Code
Requirements, local code requirements, safe working practices, and good judgement must be
used by personnel.

Heed Admonitions: Adhere to all warnings on the equipment and in the operating
instructions. Follow all operating and use instructions. Two safety admonitions are used in
this instruction manual to indicate:

• Equipment damage–

• Personal injury or injury that may result in death–

Mounting: Mount the equipment only as recommended by the manufacturer. Situate the
equipment away from heat sources such as radiators, heat registers, stoves, or other
equipment (including amplifiers) that produces heat.

CAUTION

This safety admonition applies to an operating or maintenance procedure, practice or
condition which, if not strictly observed, could result in damage to the equipment or
database.

DANGER

This safety admonition applies to an operating or maintenance
procedure, practice or condition which, if not strictly observed, could
result in serious personal injury or death.



Choreographer!™ Network Manager Installation and Operation Foreword

January 1999 6880492G07-C vii

Power Sources and Grounding: Connect the equipment to the type of power source
described in the installation instructions or as marked on the equipment. Take precautions to
avoid defeating the grounding or polarization provisions of the equipment. Disconnect the
power to the equipment by a circuit breaker when left unused for long periods of time.

Cleaning: Clean the outside of the equipment by using only a damp cloth. Do not immerse the
equipment in any type of liquid, including water. Do not use liquid cleaners or aerosol
cleaners. Dirt or other foreign matter should not be allowed to accumulate in the interior of
the enclosure.

Damage Requiring Service: Do not attempt to perform service functions that are not
described in the operating instructions. All other servicing should be referred to qualified
service personnel.

Telephone Line Installation: All telephone line connections to the equipment should be
accomplished with the telephone lines disconnected from the network interface.

Motorola is not responsible for static damage to equipment not sold under the Motorola logo.

 Motorola, Inc. 1999. All rights reserved. Printed in the U.S.A.



Foreword Choreographer!™ Network Manager Installation and Operation

viii 6880492G07-C January 1999



Revised July 1997 ix

08
/0

1/
97

PSG Limited Equipment Warranty
for U.S. And Canadian Markets

General Terms

1.  Motorola Paging Systems Group (PSG) manufactured infrastructure equipment is
warranted to be free from defects in material and workmanship to the original purchaser
only as set forth herein.

2. This Warranty covers only that equipment identified in paragraph 1 that is used in the
manner and for the purpose intended.

3. This Warranty specifically excludes any and all software products from any source. PSG
software products are the subject of the PSG Software Maintenance Program, addressed
separately.

4. This Warranty shall commence 30 days after the date of shipment of the PSG
infrastructure equipment.

5. The term of Warranty for all PSG infrastructure equipment, except for AlphaMate 250
paging entry terminal products, is one (1) year parts and labor. The term of Warranty for
AlphaMate 250 paging entry terminals is one (1) year parts and 120 days labor in
Motorola PSG-authorized service centers. In-field labor for warranty claims (excluding
AlphaMate 250 products) will be provided by Motorola PSG-authorized service centers
during normal business hours.

Limitations and Qualifications of Warranty

6. LIMITATION—THE REMEDY UNDER THIS WARRANTY IS LIMITED TO
MOTOROLA'S REPAIR OR REPLACEMENT OF DEFECTIVE EQUIPMENT. THIS
WARRANTY IS IN LIEU OF ALL OTHER WARRANTIES OR CONDITIONS,
EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE.
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7. This Warranty does not cover, nor include a remedy for, damages, defects or failure
caused by:

a. The equipment or any part of it NOT having been installed, modified, adapted,
repaired, maintained, transported or relocated in accordance with Motorola
technical specifications and instructions;

b. Storage not conforming to the Shipping, Receiving, and Installation section of the
applicable Motorola Equipment Manual;

c. Environmental characteristics not conforming to the applicable Motorola
Equipment Manual;

d. Nonconformance with the Equipment Operating Instructions in the applicable
Motorola Equipment Manual;

e. External causes including, without limitation, use in conjunction with incompatible
equipment, unless such use was with or under Motorola's prior written consent;

f. Cosmetic damages;

g. Damages caused by external electrical stress;

h. Lightning;

i. Accidental damage;

j. Negligence, neglect, mishandling, abuse or misuse;

k. Force Majeure; and

l. Damage caused by Shipper(s).

Return of Equipment

8. If an item of PSG infrastructure equipment malfunctions or fails in normal use within the
Warranty Period:

a. The Customer shall promptly notify the Motorola Paging One-Call-Support
Center at 1-800-520-PAGE (7243) as to the problem and provide the serial number of
the defective item. Motorola shall, at its option, either resolve the problem over the
telephone or issue a Return Authorization Number to the Customer. The Customer
shall, at its cost, ship the item to the Motorola Paging One-Call-Support Center
location designated at the time the Return Authorization Number is issued;
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b. The Return Authorization Number must be shown on the label attached to each
returned item. A description of the fault must accompany each returned item. The
returned item must be properly packed, and the insurance and shipping charges
prepaid;

c. Motorola shall either repair or replace the returned item. The replacement item may
be new or refurbished. When refurbished, it shall be equivalent to new in operation.
When a returned item is replaced by Motorola, the returned item shall become the
property of Motorola;

d. Subject to all the terms of this Warranty and to part availability, Motorola shall
complete the repair or exchange of Motorola-manufactured equipment returned
under Warranty within ten (10) working days of receipt of the equipment;

e. Motorola shall, at its cost, ship the repaired or replaced item to the Customer. If the
Customer has requested Express Shipping, the Customer shall pay Motorola an
expedite fee; and

f. Equipment which is repaired or replaced by Motorola shall be free of defects in
material and workmanship for the remainder of the original Warranty, or for 90 days
from the date of repair or replacement, whichever is longer. All other terms of this
Warranty shall apply to such repairs or replacements.

Advance Replacements

9. During the Warranty Period:

a. At the Customer's request and for the Customer's convenience, Motorola may
supply the Customer with Advance Replacement Parts (parts furnished in advance
of Motorola's receipt of defective items). Motorola's provision of such parts will be
contingent on part availability and on the Customer's maintaining a satisfactory
credit standing with Motorola.

b.  Motorola shall ship the Advance Replacement Parts requested by the Customer
within 48 hours of Motorola determining that such service is appropriate, if stock is
available at the Motorola service location. If stock is not available, Motorola will
make reasonable efforts to locate and provide it to the Customer within ten (10)
working days.

c. The Customer shall return defective items to Motorola within thirty (30) days from
the date of shipment of the Advance Replacement Parts; failing which, Motorola
shall bill and the Customer shall pay the full current list price of the Advance
Replacement Parts.
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10. To secure payment of the list price of Advance Replacement Parts if the defective items
are not returned to Motorola, the Customer hereby grants to Motorola a purchase money
security interest in any Advance Replacement Parts.

Telephone Technical Assistance

11. During the Warranty Period, Motorola will provide the Customer with over-the-
telephone technical fault analysis free of labor charges. The Customer may call the
Paging One-Call-Support Center at 1-800-520-PAGE (7243) for assistance. For warranty
calls in excess of 15 per location per month or for non-warranty calls, Motorola shall
charge the Customer per Motorola's then-current labor rates.

 Excluded Equipment

12. The following equipment is excluded from this Warranty and is covered instead by the
Original Equipment Manufacturer's Warranty:

a. Equipment which is not an integral part of a basic system configuration and which
is not manufactured by Motorola, such as batteries and satellite dish LNBs;

b. Peripheral equipment such as printers, modems, data loggers, video display
terminals, and lightning and surge protectors; and

c. Equipment which is not listed in Motorola's Price Book.

Force Majeure

13. Motorola shall not be responsible for failure to discharge its obligations under this
Warranty due to delays by suppliers, material shortages; strikes, lockouts or other labor
disputes; disturbances, government regulations, floods, lightning, fires, wars, accidents,
acts of God, and any other causes beyond Motorola's reasonable control.

Default and Termination

14. Motorola shall have the right to immediately terminate this Warranty, and to suspend its
performance under this Warranty, upon notification to the Customer if the Customer:

a. Assigns or transfers the Customer's rights or obligations under this Warranty
without the prior written consent of Motorola; or

b. Within thirty (30) days of written demand by Motorola, fails to pay (1) any charge
for Advance Replacement Parts supplied under this Warranty, if the Customer has
not timely returned the defective items, or (2) any other amount that may be due.
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15. Notwithstanding any such termination of the Warranty to the Customer, the Customer
shall remain responsible for all amounts then due.

Limitation of Liability

16. IN NO EVENT SHALL MOTOROLA BE LIABLE FOR ANY INDIRECT, INCIDENTAL,
SPECIAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THIS WARRANTY,
EVEN IF MOTOROLA HAS BEEN ADVISED OF THE POSSIBILITY THEREOF,
INCLUDING, WITHOUT LIMITATION, LOST PROFITS AND REVENUES, FAILURE
TO REALIZE EXPECTED SAVINGS, LOST DATA OR ANY CLAIMS AGAINST THE
CUSTOMER BY A THIRD PARTY.
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PSG Limited Equipment Warranty for
Non-U.S. and Non-Canadian Markets

General Terms
1. Motorola Paging Systems Group (PSG) manufactured infrastructure equipment is

warranted to be free from defects in material and workmanship to the original purchaser
only as set forth herein.

2. This Warranty covers only that equipment identified in paragraph 1 that is used in the
manner and for the purpose intended.

3. This Warranty specifically excludes any and all software products from any source. PSG
software products are the subject of the PSG Software Maintenance Program, addressed
separately.

4. This Warranty shall commence 30 days after the date of shipment of the PSG
infrastructure equipment.

5. The term of Warranty for all PSG infrastructure equipment is one (1) year parts and
labor.

Limitations And Qualifications of Warranty

6. LIMITATION—THE REMEDY UNDER THIS WARRANTY IS LIMITED TO
MOTOROLA'S REPAIR OR REPLACEMENT OF DEFECTIVE EQUIPMENT. THIS
WARRANTY IS IN LIEU OF ALL OTHER WARRANTIES OR CONDITIONS,
EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE.

7. This Warranty does not cover, nor include a remedy for, damages, defects or failure
caused by:

a. The equipment or any part of it NOT having been installed, modified, adapted,
repaired, maintained, transported or relocated in accordance with Motorola
technical specifications and instructions;
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b. Storage not conforming to the Shipping, Receiving, and Installation section of the
applicable Motorola Equipment Manual;

c. Environmental characteristics not conforming to the applicable Motorola
Equipment Manual;

d. Nonconformance with the Equipment Operating Instructions in the applicable
Motorola Equipment Manual;

e. External causes including, without limitation, use in conjunction with incompatible
equipment, unless such use was with or under Motorola's prior written consent;

f. Cosmetic damages;

g. Damages caused by external electrical stress;

h. Lightning;

i. Accidental damage;

j. Negligence, neglect, mishandling, abuse, or misuse;

k. Force Majeure; and

l. Damage caused by Shipper(s).

Return of Equipment

8. If an item of PSG infrastructure equipment malfunctions or fails in normal use within the
Warranty Period:

a. The Customer shall promptly notify the nearest Motorola Area Customer Care
Center (CCC) of the problem and provide the serial number of the defective item.
Motorola shall then, at its option, either resolve the problem over the telephone or
issue a Return Authorization Number to the Customer. The Customer shall, at its
cost, ship the item to the Motorola Area CCC location designated at the time the
Return Authorization Number is issued;

b. The Return Authorization Number must be shown on the label attached to each
returned item. A description of the fault must accompany each returned item. The
returned item must be properly packed, and the insurance and shipping charges
prepaid;

c. Motorola shall either repair or replace the returned item. The replacement item may
be new or refurbished. When refurbished, it shall be equivalent to new in operation.
When a returned item is replaced by Motorola, the returned item shall become the
property of Motorola;
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d. Subject to all the terms of this Warranty, part availability and the clearance of
Customs, Motorola shall complete the repair or exchange of Motorola-manufactured
equipment returned under Warranty within fifteen (15) working days of receipt of
the equipment;

e. Motorola shall, at its cost, ship the repaired or replaced item to the Customer. If the
Customer has requested Express Shipping, the Customer shall pay Motorola an
expedite fee; and

f. Equipment which is repaired or replaced by Motorola shall be free of defects in
material and workmanship for the remainder of the original Warranty, or for 90 days
from the date of repair or replacement, whichever is longer. All other terms of this
Warranty shall apply to such repairs or replacements.

Advance Replacements

9. During the Warranty Period:

a. At the Customer's request and for the Customer's convenience, Motorola may
supply the Customer with Advance Replacement Parts (parts furnished in advance
of Motorola's receipt of defective items). Motorola's provision of such parts will be
contingent on part availability and on the Customer's maintaining a satisfactory
credit standing with Motorola.

b.  Motorola shall ship the Advance Replacement Parts requested by the Customer
within 48 hours of Motorola determining that such service is appropriate, if stock is
available at the Motorola service location. If stock is not available, Motorola will
make reasonable efforts to locate and provide it to the Customer within ten (10)
working days.

c. The Customer shall return defective items to the Motorola Area Customer Care
Center within thirty (30) days from the date of shipment of the Advance
Replacement Parts; failing which, Motorola shall bill and the Customer shall pay the
full current list price of the Advance Replacement Parts.

10. To secure payment of the list price of Advance Replacement Parts if the defective items
are not returned to Motorola, the Customer hereby grants to Motorola a purchase money
security interest in any Advance Replacement Parts.
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Excluded Equipment

11. The following equipment is excluded from this Warranty and is covered instead by the
Original Equipment Manufacturer's Warranty:

a. Equipment which is not an integral part of a basic system configuration and which
is not manufactured by Motorola, such as batteries and satellite dish LNBs;

b. Peripheral equipment such as printers, modems, data loggers, video display
terminals, and lightning and surge protectors; and

c. Equipment which is not listed in Motorola's Price Book.

 Force Majeure

12. Motorola shall not be responsible for failure to discharge its obligations under this
Warranty due to delays by suppliers, material shortages; strikes, lockouts or other labor
disputes; disturbances, government regulations, floods, lightning, fires, wars, accidents,
acts of God, and any other causes beyond Motorola's reasonable control.

Default and Termination

13. Motorola shall have the right to immediately terminate this Warranty, and to suspend its
performance under this Warranty, upon notification to the Customer if the Customer:

a. Assigns or transfers the Customer's rights or obligations under this Warranty
without the prior written consent of Motorola; or

b. Within thirty (30) days of written demand by Motorola, fails to pay (1) any charge
for Advance Replacement Parts supplied under this Warranty, if the Customer has
not timely returned the defective items, or (2) any other amount that may be due.

14. Notwithstanding any such termination of the Warranty to the Customer, the Customer
shall remain responsible for all amounts then due.

Limitation of Liability

15. IN NO EVENT SHALL MOTOROLA BE LIABLE FOR ANY INDIRECT, INCIDENTAL,
SPECIAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THIS WARRANTY,
EVEN IF MOTOROLA HAS BEEN ADVISED OF THE POSSIBILITY THEREOF,
INCLUDING, WITHOUT LIMITATION, LOST PROFITS AND REVENUES, FAILURE
TO REALIZE EXPECTED SAVINGS, LOST DATA OR ANY CLAIMS AGAINST THE
CUSTOMER BY A THIRD PARTY.
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Introduction 1

The Choreographer! Network Manager Installation and Operation manual explains how to manage
your messaging network with your Choreographer! network manager. The manual addresses
the site engineer and network administrators whose tasks include constructing and managing
networks.

To perform the tasks detailed in this manual, personnel should be knowledgeable in the
following areas:

• Messaging networks

• UNIX® operating system

• Telecommunications

Chapter Overview

The following chapter descriptions summarize the topics explained in each chapter:

• Chapter 1, "Introduction" provides an overview of the Choreographer! network manager
and this manual.

• Chapter 2, "Functional Description" describes the organization, function, and protocols of
the Choreographer! network manager and the methods for navigating through the
system.

• Chapter 3, "Getting Started" describes how to install system software and configure the
computer system for the software.

• Chapter 4, "Setting Up the Messaging Network" details how to set up a messaging
network in the Choreographer! network manager and describes the functions of the
various windows.

• Chapter 5, "Network Configuration" describes how to configure devices. This chapter
details how to configure network elements, how to download the configuration and the
software to the network devices, and how to optimize paging network performance
using configurable parameters.
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• Chapter 6, "Viewing Alarms and Events" describes the network alarm and event
structure, how to define alarms and events, clear alarms, and use the technician paging
feature (TechPage).

• Chapter 7, "Historical Statistics" describes the historical statistics feature, how to set up
historical statistics to collect statistics from the RF-Conductor! controller, and how to
write queries to collect statistics on specific conditions.

• Appendix A, "Abbreviations and Acronyms" provides a list of abbreviations and
acronyms with their definitions.

• Appendix B, "Backup and Restore Procedures" contains the backup and restore
procedures and copies of the scripts.

• Appendix C, "Configuring Network Printers" has optional printer configuration
procedures.

Related Publications

The following Motorola publications relate to the operation and use of the Choreographer!
network manager and the main elements of a messaging network:

• Choreographer!™ Software Interface Concepts Description,
Motorola part number 6880492G08

• RF-Conductor!™ Controller Installation Description,
Motorola part number 6880493G03

• RF-Audience!™ Receiver Installation and Operation,
Motorola part number 6880493G04

• RF-Baton!™ Transmitter Controller Installation and Operation,
Motorola part number 6880497G01

• RF-Orchestra!™ Transmitter Installation and Operation,
Motorola part number 6880493G02

• (Optional) WMG™-Administrator! Messaging Switch Administration,
Motorola part number 6880492G01

• (Optional) NIU Transmitter Controller Installation and Operation,
Motorola part numbers 6880497G10 and 6880497G15

• Current software Release Notes, containing information on the most recent updates and
changes to the Choreographer! software
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The HP® OpenView™ Using Network Node Manager also relates to the operation and use of
the Choreographer! network manager

Conventions Used in This Manual

To clarify procedures that are described in this manual, certain text conventions are used (see
Table 1-1).

Table 1-1: Conventions Used in this Manual

Convention Description

Keys

Single keyboard keys used during input appear in a Palatino font
enclosed in angle brackets.
Example:
Press <Return> to start the update process.

Command input from
keyboard

Commands entered by the reader appear in Helvetica bold type.
Example:
Type: Is^-a <Return>

System output
System responses to commands appear in Helvetica type.
Example:
COMMAND SUCCESSFUL

Menu items
Menu item names appear in bold type.
Example:
Select File from the pull-down menu.

Spaces

A carat symbol (^) means to add a space between letters in a
command input.
Example:
Type: Is^-a <Return>

<Return>

Depending on your keyboard, the <Return> key may be known
as <Enter>. This manual uses the <Return> designation,
other than those designations that are output by various system
software.

Variables
Variables that you must type into the system are shown inside
vertical brackets [ ]. Do not type the brackets.
Examples: [Latitude] , [177.12.77.34]
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The Choreographer! Network Manager Overview

The Choreographer! network manager is a network manager for voice and data
communications, used in either the two-way or one-way messaging infrastructures. The
network manager manages and configures network devices.

As an integral element of the Wireless Messaging System advanced messaging network, the
Choreographer! network manager integrates a wide range of utilities and services:

• Configuration management and software download

• Statistics monitoring

• Alarms and event monitor/event manager

The Choreographer! network manager, the pathway to the RF network, administers the
following elements of the network while linking the various network equipment:

• RF-Conductor! (RF-C!) controller: The RF-C! controller is the Motorola controller for
an RF network. The RF-Conductor! controller batches, schedules, and queues outbound
messages for transmission over the distribution network to the transmitters and
schedules inbound messages received from the receivers.

• Nucleus paging station: The Nucleus paging station is the base station that modulates
the messages for transmission over the air to the personal messaging units.

• RF-Baton! (RF-B!) transmitter controller: The RF-B! transmitter controller is the
network interface for the Nucleus paging station and the RF-Orchestra! paging station.
The RF-B! transmitter controller provides the network interface functions to enable the
Nucleus paging station and the RF-Orchestra! paging station to receive messages from
the RF-Conductor! controller. The RF-B! transmitter controller also performs digital
signal processing on messages before forwarding them to the Nucleus paging station.

• RF-Audience!(RF-A!) receiver manages inbound message transmissions from two-way
messaging units. Inbound messages are sent to the RF-Conductor! controller for
processing.

• WMG™ Messaging Switch (WMG™ MS): The WMG MS is the messaging platform that
maintains the subscriber database, receives message inputs, manages other information
services such as voice mail services, and sends messages through the RF-C! controller to
the messaging network.



Choreographer!™ Network Manager Installation and Operation / Chapter 2

January 1999 6880492G07-C 2-1

Functional Description 2

The Choreographer! network manager configures and manages voice and data subsystems in
the PSG one-way and two-way messaging infrastructure. As an integral element of the
Wireless Messaging System (WMS) advanced messaging network, the Choreographer!
network manager provides a wide range of services:

• Configuration management and software download

• Statistics monitoring

• Alarms and event monitor and manager

The Choreographer! network manager uses the Hewlett Packard (HP) OpenView Network
Node Manager (OVNNM) for many of the control windows. The Choreographer! network
manager runs on a Solaris operating system, providing additional user windows through the
X Window System Graphical User Interface (GUI).
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Choreographer! Network Manager Overview

The Choreographer! network manager provides numerous network services. This section
describes the features, specifications, and network architecture that combine to provide these
services.

Features

The Choreographer! network manager has the following features:

• Simple operation

• Graphical User Interface

• Two-phase procedure for loading software and configurations

• Protocols:

– Simple Network Management Protocol (SNMP)

– File Transfer Protocol (FTP)

– Trivial File Transfer Protocol (TFTP)

• Primary management for several Motorola RF-control and RF-distribution elements:

– RF-Conductor! controller (RF-C!)

– RF-Baton! transmitter controller (RF-B!)

– Nucleus RF paging station (through the RF-B!)

– RF-Audience! receiver (RF-A!)

– RF-Orchestra paging station (RF-O!)

– Other SNMP-compliant equipment (routers, hubs)

• Ability to run third-party applications

• Hierarchical functionality

• Modules of value-added software for paging management

• Near real-time statistics

• Historical statistics

• Ability to filter and forward events to third-party Network Management Center (NMC)
for alarm management purposes

• Ability to page a technician for specific types of alarms
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Specifications

Your system must meet the hardware and software requirements described in this section for
optimum system performance.

Hardware Specifications

The Choreographer! network manager has the following hardware requirements:

• Sun® SPARC station 20 with TurboGX frame buffer

– 256 MB RAM (Upgradable to 512 MB)

– 2.1-GB internal disk

– Internal CD-ROM drive

– 20-in. color monitor

• FastEthernet SBus Adaptor

• External 4 mm DAT tape drive

Note: Sun SPARC station models range from 256MB to 512 MB RAM.

Software Specifications

The Choreographer! network manager requires the following software:

• Solaris Operating System 2.5.1

• HP OpenView (HPOV) 5.0.1

• Java 1.1.5

• The Choreographer! network manager application software 1.4.x

• Software patches for any of the software listed
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Network Architecture

The network architecture supports a hierarchical or peer-to-peer approach for organizing
these elements. The hierarchical approach consists of a management pyramid:

• Centralized network management center

This highest level can view the entire messaging system. This level monitors the health
and status of the system and provides technical support to the regional level.

• Regional operational centers

These centers administer the terminals, controls, paging stations, and other network
devices throughout the region. The centers also provide technical support for the local
level.

• Local operations level

In this lowest tier, local operations administer the terminal, controller, paging station, and
other network devices at the local level.

A typical situation uses systems configured for hierarchical management to provide
peer-to-peer communications and control as the system manager requires. The network
security controls this communication. Each Choreographer! network manager handles its
immediate local market, distribution network equipment, paging stations, and receivers.

The Choreographer! network manager handles a three-level hierarchy of controls, alarms,
monitoring, and reports. Normally, control is limited to the local market. However, the local
operator may pass control or monitoring of the local market to an authorized remote operator
residing on another Choreographer! network manager. This control process may occur during
consultation or for reporting statistics or alarm information. A standard feature is the ability to
forward a set of critical events or alarms to higher levels within the network management
structure.

Customers send data from the local markets to the regional and nationwide network
management center for selected alarms and network reporting and analysis.

The following information is available through alarms, reports, and monitoring:

• Numbers, types, configurations, and software versions of the equipment in the network

• Paging traffic through the system

• Equipment status

• Alarms and events that affect system performance
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Management Domain

The domain of the Choreographer! network manager includes the following system elements:

• Edge network

• Paging root

• Region

• Zones

• WMG MS

Edge Network

The Edge network side of the FLEX™, ReFLEX, and InFLEXion protocol messaging
systems includes the following elements (see Figure 2-1):

• RF-C! controller

• RF-B! transmitter controller

• RF-O! or Nucleus paging station

• RF-A! receivers (ReFLEX and InFLEXion protocols only)

• Routers

SNMP is specifically designed to manage these diverse elements.
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Figure 2-1: Edge Network
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Transmitters and Receivers

The paging station accepts the messages from the system and sends them over the air. The
receiver accepts return messages from the personal communication devices (PCD). Paging
stations and receivers may be in the same or separate site locations. Each coverage area may
have several paging stations.

WMG MS

The WMG-Administrator! messaging switch (MS), a clearinghouse for all messages in the
Wireless Messaging System, provides a wide range of messaging and administrative services.
Callers access the system through the Public Switch Telephone Network (PSTN) or the
Internet. Each WMG-Administrator! MS connects to other systems in the Wireless Messaging
System through a network of land lines and satellite links.

Paging Root

The paging root graphically represents the paging network and contains logical windows. The
paging root shows the relationships of paging devices within the paging hierarchy.

Illustrations and examples shown in this explanation are for a two-way messaging system
using the InFLEXion protocol, but the principles remain similar for messaging systems using
FLEX or ReFLEX protocols.

Each paging window allows you to arrange network devices. The arrangement can show the
relationship and functionality of the devices within the paging system instead of their actual
or logical interconnections in the network.

The Choreographer! network manager provides a way to create hierarchical sequences of
windows. Each window may have multiple icons for various devices and logical groupings.
Using specific rules (see Chapter 4, "Setting Up the Messaging Network"), you can create a
graphical representation of the paging operations.

All messaging devices have associated paging symbols. Only the symbols associated with a
window are available for use in that window.

Region

A region is the geographical area that represents the logical groupings of the business
operations of the paging network.
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Controllers

The controllers are the network devices that control the messaging traffic, receive messaging
data, and route it to the appropriate transmitter. The controllers also relay data back to a
messaging terminal and batch and schedule messaging protocols

Zones

A zone is the first level of coverage in a messaging system. Zones define a broadcast area for
the RF-C! controller.

Paging Stations and Receivers

Within the zones, you have all paging stations and receivers for that zone.
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System Navigation

The Choreographer! network manager provides a method for configuring, maintaining, and
controlling the information depicted in HP OpenView windows. The Choreographer!
network manager functionally consists of a combination of HP OpenView windows,
application-specific GUIs, and a variety of other windows.

Hewlett Packard OpenView Windows

The HP OpenView windows software develops pictorial representations of the paging system
network. HP OpenView windows have a common appearance. The information varies from
window to window, but the location of the following four areas remain consistent: menu bar,
tool bar, viewing area, and status area (see Figure 2-2).

Figure 2-2: HP OpenView Window Example

Menu Bar

Toolbar

Viewing
Area

Status
Area
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For more detailed information on the HP OpenView Windows, refer to the following HP
documents:

• HP OpenView Using Network Node Manager

• HP OpenView Solutions Catalog

Menu Bar

The menu bar appears near the top of the window and contains the OpenView Window
(OVW) menu items for accessing and controlling the operation of the network management
station.

Toolbar

The OVW displays a toolbar directly below the menu bar on each window. The toolbar
contains several icons to close the current window or access a different window. The following
icons appear from left to right in the toolbar.

The Close icon closes the current window.

The Home icon accesses the Home window. You can select any
window to be the Home window.

The Root icon accesses the Root window. In the Choreographer!
network manager, the Root window and the Home window are the
same.

The Jump icon goes back one window from the current window.

The Shortcut icon accesses frequently used windows quickly.

The Zoom icon enlarges details within a window and pans from
area to area. Selecting this icon displays a reduced window
identical to the current window.

The HP OpenView ID icon provides the copyright date, session
ID, server name, and access to information about registered
applications. When you select this icon, the About OpenView
window appears.
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Viewing Area

The actual network information appears in the viewing area. Symbols and graphics convey
information about systems, connections, and other parts of the network.

Status Area

Messages on the status area indicate the status of OVW or integrated applications. This
information is only available for applications that report status to OVW. The OVW displays
the following information on the status bar:

• Name of the root window

• Access available on the open window: read-only or read-write

• Name of the current window

• Status of automatic layout (enabled or not enabled) for the current window

About OpenView Window

The About OpenView window displays the version, copyright, and description
(see Figure 2-3). You can access the About OpenView window from any Choreographer!
network manager window by clicking the HP OpenView ID icon.

Figure 2-3: About OpenView Window

You can view active applications information by clicking the Applications button. The
Application Index window appears (see Figure 2-4).
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Figure 2-4: Application Index Window

Configuration Windows

The SNMP Management Information Base (MIB) browser provides a means of accessing
network information. The Management Information Base contains configuration and status
values that the Choreographer! network manager uses to configure the network elements.

SNMP MIB Browser

The MIB browser accesses the network information through a GUI. The MIB browser reads
the MIB elements. Use the SNMP MIB browser to monitor your network elements and to
troubleshoot problems (see Figure 2-5).

For more information about the MIB browser, refer to the HP OpenView Network Node
Manager’s User Guide (see also Chapter 3, "Getting Started").
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Figure 2-5: SNMP MIB Browser

Use the following steps to use the MIB browser:

1. Open the MIB browser by selecting Misc:SNMP MIB browser from the pull-down
menus in the HP OpenView root window.

The Browse MIB window appears.

2. Specify the MIB object to view by one of these methods:

– Type the MIB Object ID.

– Select the MIB Object from the selection list. Move through the MIB tree by using the
navigation buttons: Up Tree and Down Tree.

3. Click on the Start Query or Set button to begin.
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Paging Application Windows

The paging application windows provide navigation, configuration, and software download
windows.

A messaging system design is a hierarchy. Each level in the system breaks down or expands
into more detail. The paging configuration windows display the system design in the same
top-down configuration as the SNMP MIB browser.

The tree starts in a collapsed configuration. To find any particular element, expand various
levels of the system to locate a specific item or device.

Paging Root Windows

The Paging Root windows define the actual operational system. Paging Root windows
display the levels of the network and provide access to add and delete components of these
levels.

Background maps and icons distinguish Paging Root windows and represent operational
divisions of the system, such as regions.

Using IP Internet Windows

The IP Internet windows show the physical network layout. These windows indicate how
devices connect to each other in the network.

CAUTION

IP Internet windows are used for viewing only. The software surveys the network
and automatically adds or deletes elements without operator input. Do not manually
add or delete network elements.
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The following HP icons are used on the IP Internet windows:

Only example windows appear in this text because the windows are similar. The screens do
not necessarily contain the icon for each workstation. All IP addresses shown are for example
only. Use the left mouse button unless otherwise noted.

Shaded icons represent objects that have child submaps; therefore, you can tier down the
hierarchy. Unshaded icons have no child submaps. You cannot traverse the hierarchy further
than the IP Segments.

Use the following steps to display the physical network:

Note: All of the following procedures assume that basic system configuration has already occurred.

1. On the Root window, click the Internet icon.

The IP Internet window displays all available IP addresses and gateways (see Figure 2-6).

2. Double click the Gateway icon.

The selected Gateway window displays available segments.

Gateways: Gateways are connections between different
networks, usually routers.

IP maps: IP maps are the representation of the network
connected to the gateway.

IP segments: IP segments are the representation of the
interfaces of the element.

Segments: Segments are the collection of the devices on
the same network.

Devices: Devices are elements such as hard drives,
servers, and printers. An empty box may also represent a
device or element.
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Figure 2-6: Example IP Internet Window

3. Double click any of the segments in the Gateway window.

The OpenView Windows QUESTION dialog box displays three options (see Figure 2-7).

Figure 2-7: OpenView Windows QUESTION Dialog Box

Note: Child submaps are a further definition of the submaps. The IP Segments have no child
submaps. Do not traverse further than the IP Segments in the Gateway window.

4. Click Cancel.

The dialog box closes.
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5. Return to the IP Internet window by clicking the Jump icon on the tool bar.

6. Double click an IP Segment icon.

7. The IP Map Network window shows available segments and gateways.

8. Double click a Segment icon. The IP Map Segment window appears with all available
devices and gateways.

9. Double click any of the device icons. The appropriate device window appears with the IP
address for the device.

Note: The IP Addresses have no child submaps. The operator cannot tier down the hierarchy further
than the IP address.

10. Click the Jump icon on the tool bar to return to the IP Map Segment window.

11. Double click the Gateway icon.

The Gateway IP Segment window appears, showing the IP address for the gateway.

Using Paging Root Windows

Detailed information about using the Paging Root windows is in Chapter 4, "Setting Up the
Messaging Network". The following table summarizes the navigation available through the
Paging Root icon.

Table 2-1: Paging Root Window Functions

Window Function Access

Paging Root Displays all available regions
Double-click the Paging Root icon
on the Root window.

Region Shows all available RF-Conductor! controllers
Double-click the Region icon on the
Paging Root window.

RFC Displays all available zones
Double-click on the RFC icon on the
Region window.

Zone
Shows all available paging stations and
receivers

Double-click on the RFC icon on the
Region window.
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Using the Paging World Window

The Network Element Configuration Application (NECA) window, called Paging World,
consists of a single screen. Set up and configure your network elements from this screen.
Access this window from the OpenView pull-down menu Misc>PagingApps>Configure
Devices (NECA).

The element list is a hierarchy or indented list. Each major group of elements appears as a
single entry that expands to show the individual elements or other groups subordinate to the
selected element.

Locate any element in the system by expanding the parent group until the device appears.
Once the desired element is visible, place the cursor over the name and click the left mouse
button to select the element. The example in Figure 2-8 shows a paging network consisting of
three groups, entitled Southwest Region, Northeast Region, and Southeast Region. Each
group has two network elements; in this example, they are RF-Baton! transmitter controllers.

Figure 2-8: Viewing the Paging World Configuration Window

Note: There is no correlation between the Paging World and the topology map.

Expand the Paging Network Group to display the entire network. Use the + and - symbols to
the left of the element names to expand or collapse the view of the network.
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PNMS Element Configuration Window

Make additions and changes to your configuration by using the PNMS Element Configuration
Window (see Figure 2-9). Each group of parameters appears as a folder with the name on the
folder tab. The box does not display the entire list of folders. The scroll bar at the top right of
the right-hand box scrolls the hidden portion into view.

Figure 2-9: Using the PNMS Configuration Window
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Tool Set for Alarms, Statistics, and Configuration

The Choreographer! network manager performs the following network management tasks:

• Alarm and fault management

• Event notification

• Device status query

• Fault isolation

• Technician Paging (TechPage)

• Statistics collection and customization

• Direct entry configuration for network elements

• Maintenance and updates for network elements

Alarms

Alarms indicate the health of a messaging network by showing problems that need resolution.
However, if the alarm and fault management traffic is not addressed in a timely manner, it can
impair messaging traffic over the network. Alarm handling uses HP OpenView
methodologies.

Through the Choreographer! network manager you can also configure your system to page a
technician when a specific level of alarm occurs.

For more information on alarms, see Chapter 6, "Viewing Alarms and Events".

Statistics

The Choreographer! network manager retrieves statistics for most messaging network
activities:

• RF control

• Distribution network traffic

• Near real-time statistics
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• Paging station usage

• Receiver activity

The summary reporting functions in the Choreographer! network manager generate
additional statistics. For more information on statistics, see Chapter 7, "Historical Statistics".

Configuration

The Choreographer! network manager controls and monitors the following network
configuration:

• Network assignments, such as name, location, and numbering

• Software version

• Parameter configuration of controlled network elements

The Choreographer! network manager uses the Motorola NECA to allow you to configure
network element information (see Chapter 5, "Network Configuration").
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Standards and Protocols

The Choreographer! network manager uses the following protocols:

• Simple Network Management Protocol (SNMP)

• File Transfer Protocol (FTP) and its secondary protocols:

– Trivial File Transfer Protocol (TFTP)

– Remote Copy Protocol (RCP)

• X/Motif
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Getting Started 3

To ensure successful installation and operation of the Choreographer! network manager, you
must complete the preparation and installation procedures provided in this chapter. Complete
the information in Table 3-1 before you begin.

Table 3-1: Information Required for Installation

For this request... Supply this information for your system...

Host Name (Choreographer!)

IP Address (Choreographer!)

Netmask

Default Router IP Address

Root Password (Choreographer!)

Printer IP Address

Host Name (RF-C!)

IP Address (RF-C!)

Root Password (RF-C!)

RF-C! Version (for each RF-C!)

Host Name (for each RF-C!)
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Hardware and software specifications are detailed in Chapter 2, "Functional Description",
paragraph, "Specifications".

The Choreographer! network manager ships with a partial Solaris operating system
factory-installed. All other software must be installed on site. The site-specific information
you recorded in Table 3-1 must be typed during the installation.
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Installing the Operating System

Note: Before this procedure, you must set up the system hardware. Refer to the SUN hardware
documentation for specific setup information.

The Choreographer! network manager software ships with the Solaris software partially
installed. To finish the installation, complete the following steps to install Solaris:

Note: Names, IP addresses, and netmask entries used in this manual are examples only.
This information is specific to your site. Confirm that you have the correct information from
Table 3-1 before you type the values.

1. Place the Solaris 2.5.1 CD-ROM in the CD-ROM drive.

2. On the Sun keyboard, press <Stop> a to access the ok> prompt.

Note: The system prompts are shown.

3. Type the following command:

ok> boot cdrom <Enter>

The system comes up.

4. Select Continue twice to proceed with the installation.

5. Type the information requested by the following system prompts:

Host Name: [rfcchor2]

Select Continue.

Networked: Yes

Select Continue.

Note: The primary network interface prompts only when more than one option is available.

CAUTION

Do not attempt the installation without the necessary system knowledge and
training (see Chapter 1, "Introduction" for more information).
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Primary Network Interface: le0

Select Continue.

IP-Address: [177.12.77.12]

Select Continue. A Confirm Information dialog box appears. You have the opportunity to
change the information. Review the information for accuracy. If changes are required,
select Change. If the information is correct, select Continue.

Name Services: None

Select Continue. A Confirm Information dialog box appears. You have the opportunity to
change the information. Review the information for accuracy. If changes are required,
select Change. If the information is correct, select Continue.

System part of a subnet: Yes

Select Continue.

Netmask: [255.255.255.0]

Select Continue.

6. Select Geographic Region to define your region.

Select Set.

The Set Geographic Region screen displays.

7. Select your region in the left box. Select your time zone in the right box. Select Continue
to type the appropriate time zone parameters.

8. Set the date and time. You can accept the default format or type the time and date.

Select Continue.

A Confirm Information dialog box appears.

9. You have the opportunity to change the information. Review the information for
accuracy. If changes are required, select Change. If the information is correct, select
Continue.

The Install Solaris SW - Initial dialog box appears.

10. Select Exit.
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11. From the console, type this command:

# format <Enter>

a. The system prompts you as follows:

# Specify disk (enter its number):

Type the number of the disk as follows:

# 0 <Enter>

The format prompt appears.

b. Type the following:

format> type <Enter>

The list of format types appears.

c. Type 0 <Enter> for Auto Configure.

d. Type format> format <Enter>

The system prompts:

Ready to format. Formatting cannot be interrupted and takes 34 minutes (estimated)
Continue?

Note: This step could take longer and is dependent upon your specific system.

e. Type yes <Enter> to continue.

f. Issue the following command to proceed with the installation:

format> quit <Enter>

12. To install the Solaris software, type the following command:

# suninstall <Enter>

The Install SS - Init dialog box appears.

Select Continue to complete your installation.

13. Set the following parameters:

a. Select System Type: Standalone

b. Select Continue.

c. Select Entire Distribution plus OEM support.
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d. Select Continue.

e. Select the available disk by highlighting the disk number and selecting Add.

f. Select Continue twice.

g. Select Manual Layout.

h. Select Customize, and type the following disk partition sizes (see Table 3-2). use the
<Tab> key to navigate the table.

14. Select OK.

15. Select Continue twice.

16. Select Begin Installation.

17. Select Reboot.

Note: Solaris takes several minutes to install. On a SPARC 20, the installation may require more
than an hour.

18. Set the root password. The system prompts you to confirm the password. The factory
default password is Motorola.

Table 3-2: Disk Partition Sizes

Number Name Size

0 / 1200

1 swap 445

2 overlap 2028

3

4

5

6 /home 254

7 /usr/local 128
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19. Log in as root using the password from the previous step:

a. Login: root

b. Password: [root_password]

20. Edit the file /etc/defaultrouter  and insert the default router IP address specified in the
previous step. Use the following steps to edit this file:

a. Start a session by typing the following command:

# /usr/openwin/bin/openwin <Enter>

b. Open a UNIX shell. (Select the Shell option from the UNIX desktop menu by using
the right mouse button.)

c. Change your directory with this command:

# cd^/etc <Enter>

d. Create a defaultrouter file to define the location of your default router. Launch a text
editor and enter the following information as istructed. Type the IP address of the
default router on the first line of the file.

21. Eject the CD-ROM with the following command:

# eject <Enter>

22. Insert the Choreographer! network manager CD-ROM.

23. Change directories to the first Solaris patch by issuing the following command:

cd /cdrom/cdrom0/Solaris2.5.1/Pat.10Jul98/2.5.1_Recommended <Enter>

To access additional information, type the following:

more CLUSTER_README <Enter>

24. Install the patch cluster by issuing the following command:

# ./install_cluster <Enter>

Note: This step may require an extended time period.

25. The system issues the following prompt:

Are you ready to continue with the installation? [y/n]

26. Type y  for yes.
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27. Change your directory to the second Solaris patch by issuing the following command:

cd /cdrom/cdrom0/Solaris2.5.1/Pat.10Jul98/2.5.1_y2000 <Enter>

To access additional information, type the following:

more CLUSTER_README <Enter>

28. Install the patch cluster by issuing the following command:

# ./install_cluster <Enter>

Note: This step requires approximately 30 minutes.

29. The system issues the following prompt:

Are you ready to continue with the installation? [y/n]

30. Type y  for yes. <Enter>

31. Eject the CD-ROM with the following command:

# eject <Enter>

32. The operating system installation is now complete. Reboot your system before you
continue by typing the following commands at the command line prompt:

# sync <Enter>

# reboot^--^-r <Enter>
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Installing System Software

The installation script automates the installation procedure and reduces operator input. Use
these steps to install the Choreographer! network manager installation script:

Note: This installation should only be performed after Solaris is loaded.

1. Log in as root:

a. Login: root

b. Password: [root_password]

2. Start Open Windows by typing the following command at the command line prompt:

# /usr/openwin/bin/openwin <Enter>

Start the Installation Script

3. Insert the Choreographer! network manager CD-ROM into the CD-ROM drive and type
the following commands at the command line prompt:

# cd^/cdrom/cdrom0 <Enter>

# /usr/sbin/pkgadd^-d^.^CHOcinst <Enter>

4. If you have any conflicting files, they appear as shown in the following example:

/etc/system

usr/share/lib/zoneinfo/PRC

If conflicting files appear, type y to the following prompts:

Do you want to install those conflicting files [y,n,?,q] y  <Enter>

Do you want to continue with the installation of <CHOcinst> [y,n,?] y <Enter>

You are prompted to reboot the system.

CAUTION

There is a space on both sides of the decimal (.) in the /usr/sbin/pkgadd argument list.
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5. Reboot the system by typing the following command at the command line prompt:

# shutdown^-i6^-g0^-y <Enter>

6. Log in as root:

a. Login: root

b. Password: [root_password]

7. After the system reboots, type the following command to start OpenWindows:

# /usr/openwin/bin/openwin <Enter>

8. Use the shell tool to run the Choreographer! network manager installation script. Type
the following commands:

# cd^/opt/C_Install <Enter>

# ./start.sh <Enter>

Begin Installation

9. If the CD-ROM remains in the drive, the Welcome screen appears (see Figure 3-1). If you
removed the CD-ROM from the drive, you receive a prompt to replace it.

Figure 3-1: Welcome Screen
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10. From the Welcome screen, select the Next button to install the system software.

The Select Component to Install screen appears.

Figure 3-2: Select Component to Install Screen

11. The Select Component to Install screen allows you to specify the installation options you
will run. You can run each selection individually, or you can select the first four items
together. The following options are available:

– Install HP OpenView

– Install Choreographer!

– Install Network Printers

– Configure Choreographer!

– Backup/Restore Data

– Refresh HP OpenView License

CAUTION

If you do not have a printer to install, do not select the Install Network Printers
option. Doing this will produce unpredictable results.
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Two restrictions apply:

a. You must install HP OpenView before you can install the Choreographer! network
manager.

b. If you select the Refresh HP OpenView License option, you must have a password
validation file from HP OpenView.

Select the first four items for a new installation, then select the Next button to continue
with the installation. If you select fewer than the first four, the order of screens will differ
from the following text and graphics.

Install HP OpenView

12. Select the Next button to continue with the installation.

The Printer Setup Screen appears (see Figure 3-3).

Figure 3-3: Printer Setup Screen

CAUTION

HP OpenView will be installed with a temporary, 60-day license. To obtain a permanent
license, please complete the form enclosed with the Choreographer! network manager software
and return it to Hewlett Packard.
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13. Type the hostname or IP address of the printer and select test page.

Note: For a new installation, you must use the IP address.

After you complete the requested information, select the Next button to continue.

Configure the RF-C!

14. The configuration for the RF-C! controller begins, and the RF-C! Configuration screen
appears (see Figure 3-4). Type the Host name and the IP address for the controller from
which you are collecting data. The system prompts for this information as follows:

RF-C! Hostname: [Hostname]

RF-C! IP Address: [IP_address]

RF-C! Root Password: [root_password]

Retype Password: [root_password]

When you configure the redundant RF-C! controller, the IP address should be the
takeover IP address.

Note: This password is the root password for the RF-C! controller.

15. Select the Next button.

The system then configures the RF-Conductor! controller host IP information in the
.rhosts files, .netrc files, and etc/hosts files.

16. After you complete the configuration information, select the Next button to
continue.
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Figure 3-4: RF-C! Configuration Screen

17. The Insert Disk screen prompts you to insert the HP OpenView CD-ROM. After you
insert the CD-ROM into the drive, select the Continue button.

The installation of HP OpenView software begins, and the HP OpenView Installation
screen appears. This screen provides a progress bar in HP OpenView to measure the
progress toward completion. The progress bar proceeds to a certain point and holds there
until completion.

18. The HP OpenView installation is complete when the progress bar reaches 100
percent. When this installation step completes, the installation proceeds to the
Choreographer! network manager installation.

Select the Next button to continue with the installation.
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Install the Choreographer! Network Manager

19. The Insert Disk screen prompts you to insert the Choreographer! CD-ROM. Insert the
CD-ROM and select the Continue button.

The installation of the Choreographer! network manager software begins, and the Install
Choreographer! Application screen appears. This screen provides a progress bar so that
you can monitor the progress of the installation.

Note: If you have any problems with your installation, two troubleshooting files are available. Open a
UNIX shell to view the following files:

/tmp/C_Install.StdErr
/tmp/C_Install.StdOut

20. The Choreographer! network manager installation is complete when the progress
bar reaches 100 percent.

When the installation of the Choreographer! network manager completes, the
procedure continues to install the network printers.

Install Network Printers

As part of the printer installation, your printer drivers are automatically installed. The
HPNP JetAdmin for UNIX (SPARC) D.02.10 package is available. For information about
configuring network printers see Appendix C, "Configuring Network Printers".

21. The system prompts you to reboot your system. Select the OK button. Before rebooting,
the Choreographer! network manager displays a list of the software that was installed.



Getting Started Choreographer!™ Network Manager Installation and Operation

3-16 6880492G07-C January 1999

Accessing the Installation Menu

At any time after the installation step, use the ./setup <Enter> command to access this menu.
This command displays the Select Component to Install screen. From the screen you can make
changes or use backup and restore utility.

1. Log in as root:

a. Login: root

b. Password: [root_password]

2. Use the shell tool to run the Choreographer! network manager installation script. Type
the following commands:

# cd^/opt/C_Install <Enter>

# ./setup <Enter>
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Loading Management Information Base (MIB) Files

Network data is available in the MIB files, accessible through the MIB Browser window. The
Management Information Base (MIB) contains configuration and status values that the
Choreographer! network manager uses to configure your network elements. You must install
these files and load them into the Choreographer! network manager database before the data
are available to the Choreographer! network manager. For additional information about MIB
files, refer to the HP OpenView Using Network Node Manager manual.

Use the following steps to install the files and load them into the Choreographer! network
manager database:

1. To load the MIB tape that shipped with your network element, insert the tape into the
Choreographer! DAT drive and copy the required MIBs through a UNIX shell. Copy the
files to your Choreographer! network manager database. You can use the following
directory, /var/opt/OV/share/snmp_mibs , to store your MIBs.

Note: Refer to the specific device manual for instructions on how to load the MIBs.

2. Open HP OpenView by typing the following command:

# ovw <Enter>

3. From any Choreographer! network manager window, select Options>Load/Unload
MIBs:SNMP from the pull-down menu on the menu bar.

The Load/Unload MIBs:SNMP window appears (see Figure 3-5).

Figure 3-5: Load/Unload MIBs:SNMP Window
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4. Select the Load button.

The SNMP/Load MIB from File window appears (see Figure 3-6).

Figure 3-6: Load/Unload MIBs:SNMP/Load MIB from File Window

5. Set the filter in the Filter field by typing [MIB_path] <Enter>

6. Select the name of the directory that contains the file to load.

This action highlights the directory of the file to load. Then select the OK button to load
the file.
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7. The system may issue a warning about duplicate Date and Time. Select the Close button.

The system returns to the Load/Unload MIBs:SNMP window (see Figure 3-5).

8. Select the Close button to close the Load/Unload MIBs:SNMP dialog box.
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Event Configuration

The event configuration option allows you to add event categories that you can view. For
additional information, refer to “Managing Events” in the HP OpenView Using Network Node
Manager manual. Use the following instructions to set up events and alarms for view through
the event browser:

1. From the Paging Root screen, select Options>Event Configuration.

The Event Configuration for [hostname]  window appears.

Figure 3-7: Event Configuration Window

2. Select Edit>Configure>Event Categories from the pull-down menu.

The Event Configuration/Event Categories dialog box appears.
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Figure 3-8: Event Configuration/Event Categories Window

3. Type [network_element] Events in the Category Name field.

4. Select the Add button.

5. Select the Close button to exit the dialog box.

6. Select File>Save to save the event configuration changes you made.

7. Select the alarm MIB.

8. The traps appear as a list in the Event Identification box.

9. Double click on the traps individually.

10. Determine the number of MIB variables present in the Event Description box that you
wish to view.

11. For Event Log Message, type $[number]^$[number] .

Note: You should have a $ symbol and a number for each variable in the trap binding. Multiple
variables are separated by a space.

12. Highlight Select Category from the pull-down list. Find the category just added and
select it. In this example, the category is [network_element ] Events .
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13. Put in the severity level for the trap. Severity levels are listed on a pop-up list. Match the
trap name with its severity level.

14. After you assign all severity levels, select the OK button to continue.

15. Select File>Save to save the changes.

16. Select File>Close to close the Select Category dialog box.
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Setting Up the Messaging Network 4

After you install the Choreographer! network manager, you must set up your messaging
network in the Choreographer! network manager. This procedure defines the Choreographer
connections to the messaging network and assigns symbols for quick access. This chapter
presents the following information:

• “Messaging Network Components” provides a description of the devices you can set up
in a messaging network.

• “Network Windows” describes the windows you use to access your network and how to
use them.

• “Defining the Messaging Network” explains how to set up your messaging network in
the Choreographer! network manager and define the connections.

This chapter provides information about setting up the messaging network in the
Choreographer! network manager. This information assumes that you have previously
installed all components of the messaging network. For information about installing a specific
component, refer to the documentation for that component.
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Messaging Network Components

Messaging network building blocks include messaging switches, paging stations, controllers,
and receivers for two-way messaging. The Choreographer! network manager integrates these
various components into a unified whole.

You can set up the following Motorola products into a directly integrated messaging system:

• RF-Conductor! (RF-C!) controller

• RF-Audience! (RF-A!) receiver

• RF-Orchestra! (RF-O!) paging station

• RF-Baton! (RF-B!) transmitter controller

• Wireless Messaging System—WMG Messaging Switch (WMG MS)

• Nucleus® paging station

• Routers - Vanguard 300 and 6560

Installation and setup instructions for each component are available in the documentation for
the specific component. This section provides a brief explanation of what each component
contributes to the messaging network.

RF-Conductor! Controller

The RF-Conductor! controller, center of the Motorola messaging infrastructure system, is a
paging system controller with the following responsibilities:

• Controlling message traffic

• Receiving messaging data from a messaging input device, such as a WMG MS

• Routing messaging data to the appropriate paging station

• Relaying incoming data from receivers and receiver concentrators back to a messaging
terminal, such as a WMG MS, if appropriate
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Network Windows

The operator uses three types of windows to access the network structure in the
Choreographer! network manager system:

• The IP Internet windows represent the physical network.

• The Paging Root windows represent the active operational components of the
Choreographer! network manager system.

• Browser windows access device messaging configuration, statistics, and alarm elements.

This section explains the type of windows, how to display the windows, and example screens.

IP Internet Windows

The IP Internet windows show the physical network layout. The windows indicate how
components connect in the network. For a description of the functions of these windows refer
to Chapter 2, "Functional Description". The following table (see Table 4-1) summarizes the
functions of the IP internet windows.

Table 4-1: Internet Windows Information

Window Function Access

Internet
Shows the physical network
layout

Double-click on the Internet icon on the Root
window

Name of gateway Displays all available segments
Double-click on the gateway icon on the Root
window

IP segment address
Shows available segments and
gateways

Double-click on the IP segment icon on the
Internet window

Segment name and
address

Displays all available devices
and gateways

Double-click on the segment icon from the IP
segment window

Segment name and
address

Displays all available devices
and gateways

Double-click on the segment icon from the IP
segment window

Device address
Shows all IP addresses for all
available devices

Double-click on the device icon from the IP
segment window
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Paging Root Windows

The Paging Root windows define the actual operational system. Paging Root windows
display the operational levels of the network, and provide the ability to add and delete
components of these levels.

Background maps and icons distinguish Paging Root windows and represent operational
divisions of the system (see Figure 4-1).

Figure 4-1: Root Window

CAUTION

IP Internet windows are used for viewing only. The software surveys the network
and automatically adds or deletes elements without operator input. Do not manually
add or delete network elements.
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The following icons represent the operations hierarchy:

The Region icon can only be used on Root window.

The RFC (RF-C! controller) installation icon can only be
used on Region windows for Models 3100 and 3110.

The RedRfcII (RF-C! redundant controller) installation icon
can only be used on RF-C! windows as a container for the
prime and backup RF-C! controllers.

The RFCIII (RF-C! controller) installation icon can only be
used on Region windows for Model 3300.

The RfcIIBackup installation icon can only be used on
RedRfcII windows for Models 3200 and 3210.

The RfcIIPrime installation icon can only be used on
RedRfcII windows for Models 3200 and 3210.

The Wmg installation icon can only be used on Region
windows.

The Zone icon can only be used on RFC windows.

The Transmitter icon (representing paging stations) can
only be used on Zone windows.

The Receiver icon can only be used on Zone windows.
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The paging system example in the next figure illustrates a potential configuration using the
RFCIII (Model 3300).

Figure 4-2: Example of a Paging System Hierarchy

Displaying the Root Window

When you open HP OpenView, the system information window appears, then the Root
window appears. The Root window includes the IP Internet icon and the Paging Root icon
(see Figure 4-1). In Table 4-2, the Paging Root windows are defined by function and the
method of access is described.

RFCII Prime RFCII Backup

RedRFCIIRFC

RFCIII

Model 3100 or 3110

Model 3300

Model 3200 or 3210

Model 3200 or 3210 Model 3200 or 3210
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Note: Transmitters and receivers have no child submaps. You cannot traverse the hierarchy further
than the transmitters and receivers in the Zone window.

Table 4-2: Paging Root Windows Information

Window Function Access

Root
Shows the Paging Root icon
and provides access to the
other windows

Open HP OpenView

Paging Root Displays all available regions
Double-click on the Paging Root icon on the
Root window

Region
Shows available network
elements in that region

Double-click on a region icon on the Paging
Root window

Network Element
Displays all available zones in
that region

Double-click on the network element icon from
the region window

Zone Displays all available zones
Double-click on the zone icon from the network
element window

Transmitters and
Receivers

Shows all available transmitters
and receivers

Double-click on the device icon from the zone
window
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Browser Windows

Four areas of system access use browser windows:

• Device configuration

• Software download

• Statistics

• Events

All browser windows contain menu bars, activity boxes, and status bars (see Figure 4-3).
Additional information on using the browser windows is in paragraph, "Event Browser" in
Chapter 6, "Viewing Alarms and Events"

Figure 4-3: Example of an All Events Browser Window
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Defining the Messaging Network

After your system components are set up and installed, define the network in the
Choreographer! network manager. Use the instructions in the following sections to define
your system.

Prepare to Define the Network

You must be logged in as root and you must have HP OpenView open.

1. Log in as root:

# Login: root <Enter>

# Password: [root_password] <Enter>

2. Start HP OpenView with the following command:

# ovw <Enter>

The HP OpenView Root window appears (see Figure 4-1).

Note: Background maps are not automatically installed. For instructions on setting up maps, refer to
the HP OpenView Using Network Node Manager manual.

Set Up Paging Root

You must set up your paging root exactly as described in these steps:

1. Select Edit>Add Object from the Root screen.

The Add Object Palette appropriate for the current hierarchy level opens (see Figure 4-4)

2. From the Symbol Classes, select the Paging symbol.

The Symbol Subclasses for Class Paging appear below the Symbol Classes.
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3. Drag the Paging Root symbol to the Root screen while holding down the middle mouse
button.

The Add Object dialog box opens (see Figure 4-5).

Figure 4-4: Add Object Palette

Note: You cannot add an element that does not belong to the current level of the hierarchy. For
example, only a region may be added to a Paging Root window.
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Figure 4-5: Add Object Dialog Box

4. Label the paging root by typing [paging_root_label] in the dialog box. You can specify a
paging root label that is specific to your system.

Note: Your network elements must have unique names.

In the dialog box, select the following buttons:

a. Select Yes for Display Label.

b. Select Explode for Behavior.

c. Select the OK button.

The Paging Root symbol appears on the Root screen as shown in Figure 4-6.
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Figure 4-6: Root Window Displays the Paging Root

Set Up Region

The following procedures set up the region:

1. Open the Paging Root window as follows:

a. Highlight the paging root symbol with a double click. This warning appears:
The object does not have a child submap.

b. Select the OK button to proceed.

2. Select the region symbol from the Add Object Palette (see Figure 4-4) by highlighting the
symbol.

3. Drag the region symbol to the Paging Root screen while holding the middle mouse
button down.

The Add Object dialog box opens (see Figure 4-5).

4. Label the region symbol with its selection name and select the OK button (see
Figure 4-7).
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.

Figure 4-7: Example of a Paging Root Window

Set Up Network Element

Use the following instructions to set up your network element. These instructions use the
RF-C! controller as an example.

1. Double click the region symbol to open the region window.

2. From the Add Object Palette (see Figure 4-4), highlight the RFC symbol (Models 3100 and
3110).

3. Holding the middle mouse button down, drag the RFC symbol to the Region window.

The Add Object dialog box opens (see Figure 4-5).

4. Label the RFC symbol with its selection name in the Add Object dialog box.



Setting Up the Messaging Network Choreographer!™ Network Manager Installation and Operation

4-14 6880492G07-C January 1999

5. Select the Paging Map Manager from Object Attributes list.

6. Select the Set Object Attributes button.

7. Type the IP Address of the RF-C! controller (Models 3100 and 3110).

8. Select the OK button to exit the Add Object dialog box.

Set Up Multiple RF-C! Controllers

You can define multiple RF-C! controllers. The procedures for setting up multiple controllers
are described in this section:

• For a stand-alone system, use the procedure in paragraph, "Set Up Network Element" to
set up each stand-alone controller (for Models 3100 and 3110).

• For a backup or redundant system, use the RedRF-C! II symbol (for Models 3200 and
3210) to represent the redundant system. This system allows login for viewing only. The
system polls every ten minutes to determine which system is prime. When the prime
changes, the system issues an alarm and the text on the icon changes from prime to
backup.

• When you define multiple network elements, use the RFCIII symbol (for Model 3300) to
hold the symbols for the multiple elements.

Use the following instructions to set up a system that has a stand-alone RF-C! controller
(Model 3100 or 3110) and a redundant RF-C! controller (Model 3200 or 3210) in one system
(Model 3300):

1. Open the Region window by double-clicking on the region icon from the Paging Root
Window.

2. From the Add Object Palette (see Figure 4-4), highlight the RF-C! III symbol.

3. Hold the middle mouse button down and drag the RF-C! III symbol to the Region
window.

The Add Object dialog box opens (see Figure 4-5).

4. Label the RFC symbol with its selection name in the Add Object dialog box. The example
uses rfc3  for the selection name (see Figure 4-8).
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Figure 4-8: Region Window

5. Open the RF-CIII symbol with a double click.

The rfc3 screen appears (see Figure 4-9).

6. Set up the RF-C! (see paragraph, "Set Up Network Element").

7. Set up the redundant RF-C! controller (RedRFCII) as follows:

Note: You must type an IP address for the RF-C! controller Models 3100 and 3110. For the RF-C!
controller Model 3300 and the RedRFCII container, you may use the hostname. For the
RFCIIPrime (Models 3200 and 3210) and the RFCIIBackup (Models 3200 and 3210), you
must specify the IP address for each.

a. From the Add Object Palette (see Figure 4-4), highlight the RedRFCII symbol.

b. Drag the RedRFCII symbol to the Region window while holding the middle mouse
button down.
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The Add Object dialog box opens (see Figure 4-5).

c. Label the RedRFCII symbol with its selection name in the Add Object dialog box
(see Figure 4-5).

Figure 4-9: Redundant RF-C! System

8. Set up the RFCIIPrime system as follows:

a. Open the RedRFCII symbol (rfc2 ) with a double click.

b. From the Add Object Palette (see Figure 4-4), highlight the RFCIIPrime symbol.

c. Drag the RFCIIPrime symbol to the RedRFCII window while holding the middle
mouse button down.

The Add Object dialog box opens (see Figure 4-5).

d. Label the RFCIIPrime symbol with its selection name in the Add Object dialog box
(see Figure 4-10).

e. Select the Paging Map Manager from Object Attributes.

f. Select the Set Object Attributes button.
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g. Type the IP Address of the RFCIIPrime controller.

h. Select the OK button to accept your setup.

Figure 4-10: Prime and Backup RF-C! Controllers

9. Set up the RFCIIBackup system as follows:

a. Drag the RFCIIBackup symbol to the RedRFCII window while holding the middle
mouse button down.

The Add Object dialog box opens (see Figure 4-5).

b. Label the RFCIIBackup symbol with its selection name in the Add Object dialog box
(see Figure 4-10).

c. Select the Paging Map Manager from Object Attributes.

d. Select the Set Object Attributes button.

e. Type the IP Address of the RFCIIBackup controller.

f. Select the OK button to accept your setup.
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10. Set up the controllers with zones (see Figure 4-11), transmitters (see Figure 4-12), and
receivers (see Figure 4-12) for your paging system using the same procedures you used
for the network elements.

a. Highlight and drag the symbol to the appropriate level screen

b. Label the object in the Add Object dialog box. Select the paging map manager and
set the object attributes to define the IP address for each object.

Figure 4-11: RF-C! Window
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Figure 4-12: Zone Window



Setting Up the Messaging Network Choreographer!™ Network Manager Installation and Operation

4-20 6880492G07-C January 1999

Adding and Removing Objects

You can add objects that represent elements to the windows within the messaging hierarchy.
However, the windows only contain certain icons or objects (refer to paragraph, "Paging Root
Windows"). To add an object to a window, use the procedure you used to define your
messaging network (see paragraph, "Defining the Messaging Network").

Note: Be careful using the delete function because there are no confirmation windows.

1. Select the object to be deleted by selecting the icon on the window.

2. Choose Edit>Delete>From all submaps from the pull-down menu, then release.

The object disappears.

CAUTION

HP OpenView provides a method to delete objects from views. This method is
accessible through the Edit>Cut pull-down menu. However, this method is
incompatible with the Choreographer! network manager for Paging Root and any
elements under Paging Root. Therefore, do not use this deletion method. The correct
method for deleting messaging elements from a window is through the
Edit>Delete>From all submaps menu.
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Network Configuration 5

A network design consists of all the devices associated with the network and how they are
connected. Configuration, the assignment of device parameter values, is crucial to optimal
performance of the network design.

A network is not static. New technology and devices require that you change device
configurations or add new devices.

Use the following tools to configure your network element and to make these changes:

• To make changes for the RF-Conductor! (RF-C!) controller use the vi text editor, the
SNMP MIB browser, or the WMS-Data Operator Console (Maintenance Tool).

For additional information about use of the vi text editor, refer to your UNIX
documentation. For additional information about using the WMS-Data Operator Console
(Maintenance Tool), refer to the RF-Conductor! Controller Administration manual. For
additional information about using the SNMP MIB browser, refer to the RF-C! Controller
Software Installation manual and the HP OpenView Using Network Node Manager manual.

• To make changes for the RF-Baton! (RF-B!) transmitter controller, the RF-Audience!
(RF-A!) receiver, and the Nucleus paging station use the Network Element Configuration
Application (NECA) in the Choreographer! network manager. Refer to paragraph,
"Launching the Network Element Configuration Application" for operational
information.

• To make changes for other devices, such as the WMG and the Network Interface Units
(NIUs) use the stand-alone configuration tools.

For additional information for the WMG and the NIUs, refer to the NIU Transmitter
Controller Installation and Operation manuals (Motorola part numbers 6880497G10 and
6880497G15).

Note: Contact your Sales Representative for FLEX protocol-related information. See the Release
Notes for the current release of the Choreographer! network manager and the hardware in the
messaging network.
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Configuring the RF-Conductor! Controller

To configure the RF-Conductor controller, you may use three options:

• Text editor

• SNMP MIB browser

• WMS-Data Operator Console (Maintenance Tool

Use these options to add, modify, and delete devices and parameters for the RF-Conductor!
controller. Parameter information is in the RF-Conductor! Controller Software Installation
manual or the Choreographer! Software Interface Concepts Description manual.

Text Editor

The Choreographer! network manager uses a text editor as the configuration tool for the
RF-Conductor! controller. Use a text editor to define the system parameters for a large
configuration. A large configuration could be an installation or adding or deleting a channel.
Refer to the user documentation for the editor that you use for information about the editor.

Note: This option may be quicker than the other options, but it is more conducive to errors. There is
no validation available with this option.

MIB Browser

After your initial configuration, you can use the MIB browser to change your parameters. You
access the MIB browser through the HP OpenView root window (Misc>SNMP MIB
Browser). For additional information about the MIB browser, refer to the HP OpenView Using
Network Node Manager manual or the RF-C! Controller Software Installation manual.

WMS-Data Operator Console

To access the Maintenance Tool from the Choreographer! network manager, highlight the
RF-C! II prime or back-up icon (Model 3200 or 3210) from the Paging Root Window and select
the following menu item: Misc>Paging Apps>Viewer Maint Tool. If you have administrative
authority, select the Admin Maint Tool option from the same menu.

For additional information about using the WMS-Data Operator Console (Maintenance Tool),
refer to the RF-Conductor! Controller Administration manual.
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Configuring the Network Element

The Choreographer! network manager uses the Network Element Configuration Application
to configure the RF-Baton! transmitter controller, the RF-Audience! receiver, and the Nucleus
paging station.

Launching the Network Element Configuration Application

The Network Element Configuration Application browser launches from any HP OpenView
window (see Figure 5-1).

Note: Use the left mouse button unless otherwise specified.

To open the Network Element Configuration Application, select
Misc>Paging Apps>Configure Devices (NECA).

Figure 5-1: HP OpenView Root Window



Network Configuration Choreographer!™ Network Manager Installation and Operation

5-4 6880492G07-C January 1999

When the application opens, the Paging World browser appears (see Figure 5-2). From this
screen, you can set up and configure your network element.

To display the groups, select the icon to the left of the Paging Network Group. The element
groups appear in a hierarchical list. To display the elements in each group, select the + button
to the left of the group name.

Figure 5-2: Displaying the Paging Hierarchy

Setting Up Network Elements

You must set up your paging network in groups. The groups are subdivided into network
elements or additional subgroups. To set up your paging model, you must set up your groups
and the network elements in each group.

Setting Up Paging Groups

Paging groups are the first division in the paging model. A folder represents each group. Use
these steps to set up your paging group:

1. Highlight the Paging Network Group by clicking once on the name.

2. With the paging group highlighted, select Edit>Add Folder.

The Add Folder dialog box appears (see Figure 5-3).

3. Specify the name of the group. In the configuration sample model (see paragraph, "Using
the Paging World Window"), the next group could be named Northwest.
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Figure 5-3: Setting Up Network Element Groups

4. Verify that you typed the name correctly, then select the OK button.

5. Repeat this process until you have set up all of your groups.

Setting Up the Network Elements

To set up your network elements for each group, complete these steps:

1. Highlight one of the paging groups you created.

2. With the group name highlighted, select Edit>Add Element.

3. The Add Element dialog box appears with the following active fields (see Figure 5-4).

4. Complete these fields as follows:

– Element Type/Version is the type of the network element you are configuring (such
as the RF-Baton! transmitter controller or the RF-Audience! receiver) and the software
version of the network element.

– Address is the IP address of the network element you are configuring.

– Protocol identifies the protocol used in the configuration (SNMP).

– Key acts as a password. If the protocol is set to SNMP, key is equivalent to a
community value.

5. The drop-down list of device types and versions from which the user will choose the
network element is in this dialog.

6. Verify that you completed these fields correctly, and select the OK button.

7. Repeat these steps for each network element in each group.
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Figure 5-4: Setting up the Network Elements

Using the Paging World Window

The Network Element Configuration Application (NECA) window, called Paging World,
consists of a single screen (see Figure 5-5). You set up and configure your network elements
from this screen.

The element list is a hierarchy or indented list. Each major group of elements appears as a
single folder entry that expands to show the individual elements or other groups subordinate
to the selected element.

You can locate any element in the system by expanding the parent group until the device
appears. Once the desired element is visible, place the cursor over the name and click the left
mouse button to select the element. In this example the paging network consists of three
groups, entitled Southwest Region, Northeast Region, and Southeast Region. These regions
are for example only; they do not represent an installation. Each group or region consists of
two network elements, in this example the elements are RF-Baton! transmitter controllers.
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Figure 5-5: Viewing the Paging World Configuration Window

Displaying Elements of the Paging Hierarchy

You can expand the Paging Network Group to display your entire network. Use the + and -
symbols to the left of the element names to expand or collapse the view of your network.

1. To display the groups, select the icon to the left of the Paging Network Group.

The element groups appear in a hierarchical list.

2. To display the elements in each group, select the + button to the left of the each group
name.

The fully expanded Paging World screen appears in Figure 5-6. You can also have subgroups
within the folders.
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Figure 5-6: Viewing the Paging Hierarchy

Entering and Modifying Parameters

The Choreographer! network manager uses the Network Element Configuration Application
(NECA) as the configuration tool for the network elements. NECA sets up and configures
your paging network and allows you to specify the parameters for your network elements.
You make additions and changes to your configuration by using the Paging Network
Management System (PNMS) Element Configuration Window.

Accessing the PNMS Element Configuration Window

To access the configuration window, highlight the elements you will configure and select the
Configure>Network Element pull-down menu from the Paging World browser. You can
configure a single network element (see paragraph, "Configuring a Single Network Element"),
or you can configure multiple network elements of the same type (see paragraph,
"Configuring Multiple Network Elements"). For example, you can select four RF-B!
transmitter controllers that are in the group and configure them simultaneously.

Using the PNMS Element Configuration Window

The PNMS Element Configuration Window, or parameter list, lists all groups of configurable
parameters for the selected element (see Figure 5-7). Each group of parameters appears as a
folder. The box does not display the entire list of folders. To view the additional items, click on
the scroll bar at the top right of the right-hand box. The hidden portions scroll into view.
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Figure 5-7: Using the PNMS Element Configuration Window

The left-hand column shows the chosen element names, and the right-hand box shows the
parameters and the fields for the corresponding values. The grayed parameters are read-only.
Use the following buttons as described:

• The Select Similar Elements button selects all network elements of the same type with
the same version in the group you are configuring. Use this feature when you are
configuring devices of the same type.

• The Send button accepts new values and initiates the system update. Use this feature to
change parameters. The Send button is only active when you type a value.
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• The Query button displays current values. You cannot use Query when you have more
than one device selected. If you select the Query button while a main parameter group is
highlighted, the values for that group appear. If you select the Query button while a
subparameter group is highlighted, the values for all subgroup parameters within that
main group appear.

• The Clear all button removes all parameter values for the selected element. Use this
feature to prepare to reconfigure all parameters. Using this button clears the values on
the PNMS screen; the button does not clear the values on the device. The device values
are not changed until you download the configuration.

Configuring a Single Network Element

You can configure each network element individually, or you can configure all similar
elements in a paging group simultaneously. To configure by group, see paragraph,
"Configuring Multiple Network Elements". Read all procedures before you begin.

Use the following procedures to configure a single network element or to edit existing values:

Note: Use the left mouse button to perform all actions unless otherwise specified.

1. Select the Element name on the Paging World window.

2. With the Element name highlighted, select Configure>Configure Element.

The PNMS Element Configuration Window appears (see Figure 5-7). The left-hand box
in the window displays the element you selected. The right-hand box displays the
parameter groups you can configure.

3. Select the Tab at the top of the right-hand box to select the group to configure.

The parameters for that group appear. You can set any parameters that are not grayed.
You can configure any number of fields, only the fields that have been configured will be
sent to the device. The fields accept alphanumeric input. A small box in the field accesses
a list of choices for the field.

Some parameter groups are divided into subgroups. These subgroups appear as folder
tabs along the bottom of the right-hand box.
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4. Use the three buttons for specifying parameters as follows:

a. Use the Send button if you change any values. Only the values that you changed are
sent to the devices.

Note: The Send button becomes active when you type new parameter values.

b. Use the Query button to display the current values for the selected element. If you
query for values and a field appears blank, use the scroll bar at the right end of the
field to bring the values into view. If you begin the query from a subgroup, the
query populates all subgroup values for that main group.

c. Use the Clear All button to remove all parameter values for the selected element.

Configuring Multiple Network Elements

You can apply the configuration changes to multiple elements if they are in the same group.

Note: If a field is grayed, you cannot update it simultaneously with others. You must edit it for each
network element after you complete the multiple configuration.

1. Configure one element as described in paragraph, "Configuring a Single Network
Element", and record the values you configure for that first element.

2. Select the multiple elements by either of two ways:

a. Select the Select Similar Elements button to configure all elements of the same type
(For example, RF-Baton!) in that group.

b. Highlight multiple elements in the left-hand box by clicking on each element one
time. This method clears the parameter fields in the right-hand box.

3. Type the parameter values.

4. Select the Send button to update the parameters.

All configured zones appear.
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Downloading Software

The Network Element Configuration Application uses the TFTP protocol to download
software. If you plan to use NECA for software download, you must have the Choreographer!
network manager configured to use the TFTP protocol.

Note: Your network element must be partially configured before the following procedures will work.
You must have defined the IP Subnetmask Gateway Host TFTP for your network element. For
specific instructions, refer to the installation instructions for your device.

Sending new software to a device consists of two processes:

• Download, sending the new software to the device

• Cutover, or instructing the device to use the new software

The actual download copies the file to the designated elements. This feature allows you to
upgrade your software and distribute new software from a central location. Software
Download begins from the Paging World screen.

Use the following procedures to complete your software download:

1. Verify that you set up the TFTP protocol during the installation.

a. Access the /etc  directory with the following command:

# cd /etc <Enter>

b. Launch a text editor and view the inetd.conf  file.

This file has a line that begins with tftp . This line should not be commented out; it
should not have a # symbol at the beginning of the line.

c. If the # symbol is there, delete it. If it is not there, the TFTP protocol is set up.

2. Place the files you are downloading in the tftpboot  directory.

3. Select the network element where you are sending the files (For example, RF-Baton!).

4. With the network element highlighted, select Configure>Configure Element from the
pull-down menu.

The PNMS Element Configuration Window appears.
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5. Select the Software Download Group from the folder tabs displayed along the top of the
right-hand box.

6. Select the Configuration subgroup from the folder tabs displayed along the bottom of the
right-hand box.

7. Complete the IP Address and File Name fields as follows:

IP Address: [IP Address of host where file resides ]
File Name: [name of file to download ]

8. Select the Set SW Download Group button.

9. Select the Control and Status subgroup from the folders displayed along the bottom of
the right-hand box.

10. Select the Start SW Download button.

The download process begins. If you want to monitor the progress, you can open
multiple configuration GUIs and press the Query button to obtain download status.

The download is complete when these two fields display the following status:

a. Ending State: downloadAndInstallComplete

b. Detailed Status: downloadSuccess

11. Check the status periodically by selecting the Query SW Download Group button on the
Control and Status subgroup until the download finishes.

12. Each device validates the downloaded file and sends either an affirmative or negative
response. The Choreographer! network manager collects affirmative or negative
responses from the devices. You receive notification of all responses.

13. A cutover can be performed through the Cutover button on the control and status
subgroup. You can verify that the cutover occurred properly by:

a. Verifying your Dormant Software version on the Station Control group folder.

b. Checking the software version on the Software Version folder.

If the version numbers are the identical, cutover is complete. If the version numbers are
not identical, check the status through the Control and Status subgroup.
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Viewing Alarms and Events 6

The Choreographer! network manager monitors network events through HP OpenView.
Events include device status and network information alarms. Events are actions and
indications that the operator is not required to clear. Alarms are indications of problems that
an operator must take action to clear.

Note: The behavioral characteristics of a managed element are controlled by the element Simple
Network Management Protocol (SNMP) agent and the element, not by the Choreographer!
network manager.

Events and alarms reside in a database where they are available for customer-developed
filters to sort and merge information into customized reports.
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Alarm and Event Management

SNMP alarms and events appear from a Graphical User Interface (GUI) at the Choreographer!
network manager console. With projector hardware, you can project the GUI onto a wall or
screen for viewing by the operations staff.

Icons show element status and state in a hierarchical manner. Status information quickly
identifies system status from any level of operator view. For example, an alarm condition at a
receiver changes the receiver icon color to reflect the alarm severity. The zone that controls the
receiver and the RF-Conductor! controller domain that controls the zone also change to reflect
the alarm condition. You can then identify a failing element.

Alarm Categories

The network manager or the operator assigns a category level for each of the different types of
alarms. The Choreographer! network manager provides color coding of the alarm levels.
These colors and categories are fixed, and you cannot change them. (see Table 6-1).

Alarm Reporting and Monitoring Scenario

The following scenario illustrates a typical situation where operators monitor multiple
windows showing different aspects of the system. At the same time, the operators perform
actions that do not affect the same device or zone. The Choreographer! network manager map
window alerts an operator of the network current operating conditions. The following
reporting and monitoring procedure is typical:

Table 6-1: Alarm Categories

Category Definition Color

Critical
Error or failure conditions that require immediate attention
(affect service)

Red

Major
Error or failure conditions that require rapid attention but are
not as significant as critical alarms (do not affect service)

Orange

Minor Other error and failure conditions Yellow

Normal or
Informational

All other conditions Green
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• Upon receipt of an error or alarm message, the Choreographer! network manager
changes the color of the device icon affected.

• The operator selects the icon. A window presenting a more detailed regional window
appears. Another icon indicates the alarm or event condition.

• The operator clicks through a series of icons and windows until arriving at site-specific
information on the reporting device.

• The operator then goes to the event browser, gets more information about the alarm, and
takes the necessary action. The operator also decides the events that are actually reported
or simply put into a log file. The Choreographer! network manager provides visual
indications of when an alarm is acknowledged.

The network manager also configures the events to be filtered and not displayed using the
visual indicators. For example, some events are configured for passing to a third-party
centralized alarm manager, such as the MAXM network management systems.
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Alarm and Fault Management Functions

Alarm and fault management do not interfere with messaging traffic over the network. Alarm
management provides the following functions:

• Event notification

• Device status query

• Fault isolation

Alarm States

At a minimum, the alarm includes the following states:

• Active

• Acknowledged

• Cleared

Additional alarm states can be configured into the Choreographer! network manager.

Alarm Generation and Forwarding

An alarm trap is an unscheduled or unpolled message initiated by a device about its status.
Traps are defined within each device, and are generated and sent to the Choreographer!
network manager when the predefined events occur. All alarms transmit from the device to
the Choreographer! network manager in the form of SNMP traps.

If an alarm condition occurs, the device sends the alarm to the Choreographer! network
manager. The Choreographer! network manager may forward this alarm to a high-level
manager. The operator can enable or disable the alarm forwarding by editing the provided
configuration file as described in paragraph, "Configuring the AlarmManager for
Forwarding".

Scheduled device polling for detecting errors occurs on a periodic basis to ensure the device is
working properly. Detection of problems such as link errors, major software errors, or power
failures, occurs using either polling or alarm traps. Polling intervals are configurable within
HP OpenView.
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The alarm manager uses a set of HP OpenView rules to process each alarm or event to
determine the action to be taken. Certain actions can be automated through the use of a script,
such as taking devices off-line, sending out technician messages, or disabling certain types of
traffic.

Each system module (such as the RF-B! transmitter controller or the WMG) accesses
operational failures up to and including the Field Replaceable Unit (FRU) module level.

The user interface is built on top of the industry-standard SNMP version 1.0.

Refer to the HP OpenView Using Network Node Manager manual for additional information.
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Event Browser

The event browser provides access to the various event categories. When you start HP
OpenView, the Event Categories window appears (see Figure 6-1). Keep this window open
while the Choreographer! network manager is active.

Note: All actions are performed using the left mouse button, unless otherwise stated.

Figure 6-1: Event Categories Window

To close the Event Categories window without closing the application, select Close from the
window pull-down menu. The Exit Event Browser dialog box appears (see Figure 6-2).

Figure 6-2: Exit Event Browser Dialog Box

Select OK to exit.
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Event Information

Each category of events provides the following event information (see Figure 6-3):

• Acknowledgment status

• Severity of the error

• Date and time of the error

• Source of the error

• Error message

Use the following steps to access the event information:

1. From the Event Categories window, select the button for the category you will view. For
this example, select the Error Events button. The RFC Events Browser window displays
the following data (see Figure 6-3):

Figure 6-3: Error Events Browser Window

2. Select File>Close from the pull-down menu to close the window. For additional
information about using the event browser, refer to the HP OpenView document, Using
Network Node Manager.
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Alarm and Event Logging

Alarm and event logging contains two types of logs:

• System event logs

• Local event logs

System Event Logs

Historical event logs are recorded in an HP OpenView file. You can access the file from the
pull-down menu on any event browser window to read, print, and sort. Historical times are
recorded to the second.

The historical event logs are maintained in an historical database. You can sort the database
based on date, time, device, and alarm severity. The database is definable in size. When the
database reaches 4 MB in size, the newer alarms overwrite older alarms. This feature
maintains historical data yet prevents the database from using excessive system resources.
You can query the data to research recurring problems.

Local Event Logs

Each WMS subsystem maintains its local event logs. Each subsystem forwards the alarms to
the respective event manager. The local event log provides event and alarm data on the device
directly to the operator. Direct data is important if a network connection is lost or the
Choreographer! network manager is out of service.

The Choreographer! network manager combines multiple alarms, generated by the same
event, into a single-alarm notification. The single-alarm notification minimizes the total
number of alarms displayed for the same event.

The Choreographer! network manager supports a variety of applications that perform alarm
correlation analysis on the network devices to assist in corrective actions and as a part of fault
isolation. The Choreographer! network manager can resynchronize with the element alarm
logs when a lost connection is restored, if this capability is supported by the element.
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Communications to Other Network Management Stations

The Choreographer! network manager collects alarms from the messaging devices in the form
of SNMP traps. You can configure the Choreographer! network manager to forward these
alarms to other network management stations.

You can define which alarms to forward where, and you can forward alarms through the HP
OpenView or AlarmManager applications. Information, such as alarm IDs, alarm ID
description, and the source of the alarms, is included in the SNMP traps.

Configuring the AlarmManager for Forwarding

Use the following procedures for editing the configuration file:

1. Open a UNIX shell.

2. Edit the /usr/choreographer/bin/forwarding.cfg  file.

These forwarding rules apply when you edit the configuration (.cfg) files:

• This file has one rule for each line.

• Each line has three columns separated by colons.

– First column must have the source IP address or a wildcard (RFA, RFB, RFC, WMG)

– Second column must have the alarm threshold level (CRITICAL, MAJOR, MINOR) or
the specific alarm ID

– Third column must have the destination IP address

• Lines that begin with # as the beginning character are comments.

• If you make changes to forwarding.cfg , you must restart HP OpenView.

Alarm Forwarding Examples

The following example entries to this file accomplish the actions described in the comments
preceding them. Comment lines begin with the # symbol.
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Figure 6-4: Alarm Forwarding Examples

You can specify either the specific alarm ID or the threshold level to satisfy the rule. Threshold
level specifies any alarm of a severity level equal to or higher than the threshold level. If you
specify the alarm ID, then alarms whose alarm ID matches the one specified in the file satisfy
the rule.

Configuring HP OpenView for Forwarding Alarms

If you want to forward alarms through HP OpenView, refer to the HP OpenView Using
Network Node manual for instructions.

Configuring for Technician Paging

Some businesses need to have technicians notified immediately for certain alarms. You can
configure the Choreographer! network manager to page technicians. You can then specify the
category and specific IDs within the category. The TechPage application sends alphanumeric
pages in response to alarms.

The AlarmManager application on the Choreographer! network manager uses the
information in /usr/choreographer/bin/techpage.cfg  file to determine which alarms will
initiate a page. The format of the techpage.cfg  file is illustrated in the following section.

1. Open a UNIX shell

2. Edit the /usr/choreographer/bin/techpage.cfg  file by typing the following information:

– Source IP or wildcard (RFA, RFB, RFC, WMG)

– Threshold (CRITICAL, MAJOR, MINOR) or alarm ID

– Pager pin number

#The following line forwards MAJOR and CRITICAL alarms from 10.16.0.1 to 10.16.0.2
10.16.0.1:MAJOR:10.16.0.2

#The following rule forwards MAJOR and CRITICAL ALARMS from all RFBs to
RFB:MAJOR:10.6.0.2

#The following rule forwards only alarms with an alarm ID of 100 from RFAs to 10.6.02
RFA:100:10.6.0.2
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– Telephone number

– Minimum time between two pages in seconds

– From information or quotes (If a space is included, enclose in quotation marks.)

– How many times the process retries

– Description of the alarm

– Port to which the modem is connected:
- /dev/ttya
- /dev/ttyb

– Configuration The following baud rates are available:
- 24008N1
- 12008N1
- 3008N1
- 24007E1
- 12007E1
- 3007E1

– Password (If no password is required, put # sign.)

– Verbose output (To disable, put #.)

Technician Paging Example

The following example entry to this file accomplishes the actions described in the comments
preceding them. Comment lines begin with the # symbol.

Figure 6-5: Technical Paging Example

#Send a page to pin number 2452403 for all critical alarms from 199.4.71.231
199.4.71.231:CRITICAL:2452403:9,18007596366:1800:NOC:1:”Specific Type”:/dev/ttya:24007E1:#:#:
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Historical Statistics 7

The Choreographer! network manager collects a variety of statistics from the RF-Conductor!
controller (Models 3100 and 3110). The historical statistics feature assimilates statistics data
from your network element, in this case the RF-Conductor! controller, for viewing and
printing through the graphical user interface.

You can specify which parameters to retrieve and what time period to display. Using historical
statistics queries, you can perform these activities:

• Specify statistics to display

• Analyze trends

• Examine paging traffic

• Review network usage

You can view the results as a chart, a bar graph, or a table. For archiving and reporting
purposes, you can print the results or save the results to disk.
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Historical Statistics Components

The historical statistics function consists of three components: file manager, network element
manager, and query manager. These components provide the tools to display your statistics.

Historical Statistics File Manager

The file manager provides access to the application files and directories on your disk (see
Figure 7-1). The file manager shows a hierarchical view of the file structure. This model allows
you to view and maintain application files.

When you make changes with the file manager, the system prompts you to save the changes
when you exit the application.

Figure 7-1: Historical Statistics File Manager

CAUTION

You should only delete files using the historical statistics components.
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Historical Statistics Network Element Manager

All network elements, the systems from which you retrieve statistics information, are
maintained in the network element manager (see Figure 7-2). The RF-C! controller is the
only network element currently supported for historical statistics retrieval. The network
element manager is the component you use to perform the following functions:

– Add network elements

– Configure new and existing network elements

– Remove network elements

The historical statistics application attempts to retrieve statistics on a user-configurable
interval from all network elements in the network element manager.

When you make changes with the network element manager, the system prompts you to
save the changes when you exit the application.

Figure 7-2: Historical Statistics Network Element Manager



Historical Statistics Choreographer!™ Network Manager Installation and Operation

7-4 6880492G07-C January 1999

Historical Statistics Query Manager

The query manager allows you to select and view specific statistics in chart, bar, or table
format (see Figure 7-3). The results can be saved to disk and viewed later. You can also
save queries to disk and rerun them at any time if the statistics used to generate the
results have not been deleted.

When you make changes with the query manager, the system prompts you to save the
changes when you exit the application.

Figure 7-3: Historical Statistics Query Manager
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Collecting Statistics from the RF-Conductor! Controller

Before you can begin collecting statistics, you must set up and configure your network
element in the network element manager. This setup procedure allows you to complete the
following qualifications:

• Designate the network element from which you collect data

• Specify the software version of the network element

• Specify how frequently to retrieve statistics

Set-Up Procedures

The following procedures detail how to set up the network element for retrieving and
displaying statistics:

1. Before you set up the network element manager, you must copy the
RFC_<Version>_stat.dat  file from the RF-Conductor! controller to the
/home/HistStats/persistent  directory. Refer to the application installation procedures in
the RF-C! Controller Software Installation manual for additional information.

The <Version>  is the software version of your RF-Conductor! controller. For example, if
you were retrieving statistics from an RF-Conductor! Version 3.7.0, this file would be
named RFC_3.7.0_stat.dat. The software version must be the same software version that
you specify in Step 2 of paragraph, "Configure Network Element Type".

2. From the OpenView Paging World screen, open Historical Statistics by selecting
Misc>Paging Apps>Statistics (see Figure 7-4).



Historical Statistics Choreographer!™ Network Manager Installation and Operation

7-6 6880492G07-C January 1999

Figure 7-4: Launching Historical Statistics

The Historical Statistics Query Manager appears (see Figure 7-3). This screen contains a
list of saved queries and results.

3. From the Historical Statistics Query Manager (see Figure 7-3), access the network
element manager by selecting Tools>Network Element Manager.

When the Network Element Manager screen (see Figure 7-5) appears, you can setup and
configure the network elements from which you retrieve statistics.
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Configure the Network Element

From the Network Element Manager, use these steps to configure the network element:

1. Select the network element icon on the Tool Bar.

The Configure Network Element dialog box appears (see Figure 7-5), and a new icon
appears in the Historical Statistics Network Element Manager screen.

Figure 7-5: Adding a Network Element

2. Complete the following information in the Configure Network Element dialog box (see
Figure 7-6):

– IP hostname of the network element

– Software version of the software running on the network element

– Time zone where the network element is located

– Next time for retrieving statistics

Note: You must specify a hostname; an IP address is not valid. Refer to paragraph, "Configure the
Network Element" for information about adding a hostname.
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The IP hostname may only contain letters, numbers, and periods. The Choreographer!
network manager uses the retrieval interval you configured for the network element type
to calculate the next retrieval time.

Note: When you configure the next retrieval time, select a time when you have minimal paging
traffic.

Figure 7-6: Configuring the Network Element Manager

The software version must be the same software version that you specify in Step 2 of
paragraph, "Configure Network Element Type". For example, if you are retrieving
statistics from an RF-Conductor! Version 3.7.0, this field would contain 3.7.0.

Specify the time zone by selecting from the list as shown in Table 7-1

Table 7-1: Time Zone Definitions

Abbreviation Definition

GMT Greenwich Mean Time time zone.

ECT European Central Time time zone.

EET Eastern European Time time zone.

ART (Arabic) Egypt Standard Time time zone.

EAT Eastern African Time time zone.

MET Middle East Time time zone.

NET Near East Time time zone.

PLT Pakistan Lahore Time time zone.

IST India Standard Time time zone.

BST Bangladesh Standard Time time zone.
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VST Vietnam Standard Time time zone.

CTT China Taiwan Time time zone.

JST Japan Standard Time time zone.

ACT Australia Central Time time zone.

AET Australia Eastern Time time zone.

SST Solomon Standard Time time zone.

NST New Zealand Standard Time time zone.

MIT Midway Islands Time time zone.

HST Hawaii Standard Time time zone.

AST Alaska Standard Time time zone.

PST Pacific Standard Time time zone.

PNT Phoenix Standard Time time zone.

MST Mountain Standard Time time zone.

CST Central Standard Time time zone.

EST Eastern Standard Time time zone.

IET Indiana Eastern Standard Time time zone.

PRT Puerto Rico and US Virgin Islands Time time zone.

CNT Canada Newfoundland Time time zone.

AGT Argentina Standard Time time zone.

BET Brazil Eastern Time time zone.

CAT Central African Time time zone.

Table 7-1: Time Zone Definitions

Abbreviation Definition
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3. Select the OK button after you type your values. The IP hostname of your RF-Conductor!
controller appears below the new icon.

This process establishes a one-to-one relationship between the Choreographer! network
manager and one RF-Conductor! controller. The Choreographer! network manager now
begins retrieving statistics from your network element.

If you should need to change your configuration later, select the icon that represents your
RF-Conductor! controller and click the right mouse button to access the Configure
Network Element dialog box (see Figure 7-6). Make the changes in this dialog box.

4. Save your network element changes by selecting File>Save. If you fail to save your
changes, the Choreographer! network manager prompts you to save when you attempt
to exit.

Configure Network Element Type

You may also configure the network element type (see Figure 7-7). This configuration
optimizes the retrieval interval and designates where your statistics on the RF-C! are stored.

Figure 7-7: Configuring the Network Element Type

1. Access the Configure Network Element Type dialog box by highlighting the network
element icon and selecting Edit>Element Type. This step identifies where your statistics
information on the network element is stored and how often statistics are retrieved. The
grayed fields are not configurable.
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2. To configure the network element type, complete these fields:

a. The Retrieval interval field indicates how often statistics are retrieved. This value is
stated in minutes. By default, statistics are collected every 24 hours.

b. The Retrieval directory designates where you store statistics on the network
elements of this type. Specify this directory by typing the full pathname.

Note: If you are unsure of which pathname to use, contact your system administrator. We
recommend that you retrieve statistics from the /home/rfc/stats  directory.

c. When you are satisfied with your entries, select the OK button. You may cancel your
changes at any time by selecting the Cancel button.

3. Save your configuration changes by selecting File>Save. If you fail to save your model,
the Choreographer! network manager prompts you to save when you attempt to exit.
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Using Historical Statistics

The historical statistics feature provides access to the statistics collected by the network
element you select. You can create your own queries to view selected statistics over a specified
period of time.

Viewing Specific Statistics

User-defined queries allow you to display statistical information for specific conditions. You
can create your own queries to gather information about a particular station, channel, or time
interval that you need to review.

Figure 7-8: Sample Query

You can create queries to do the following activities:

• Specify statistics to display

• Analyze trends

• Examine paging traffic

• Review network usage
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Building Queries

You can create queries that collect specific information. Using these queries, the
Choreographer! network manager extracts the data you need and presents it in a reporting
format. Use the Historical Statistics Query Manager to build your own queries. Before you use
the Query Manager, confirm that you completed Step 1 in paragraph, "Collecting Statistics
from the RF-Conductor! Controller". In that step you should have copied the
RFC_<Version>_stat.dat  file from the RF-Conductor! controller to the following directory:
/home/HistStats/persistent .

From the Historical Statistics Query Manager, you can view and edit previous queries, build
new queries, save queries, and execute queries. The following icons help you perform these
activities from the Query Manager screen (see Figure 7-9):

Begin a new query

Save a query or results

Delete a result or query

Execute a query
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Figure 7-9: Using the Historical Statistics Query Manager
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The procedures for building a new query follow:

1. Select the New button from the Query Manager to create a new, empty query.

Figure 7-10: Using the Query Builder

2. The query builder is the tool where you specify the following qualifications for your
statistics query:

– which RF-Conductor! controller from which to retrieve statistics

– which statistics to display

– whether your statistics group is by hour or by day

– which dates to report

3. Complete each of the three clauses (From, Select, and Where) to build your query.

Specifying the From Clause

The From clause determines the controller and the dates to display and the method of
grouping the statistics. Use the following steps to complete the From clause:

1. When you select the From tab, the From Clause panel appears (see Figure 7-11).

In this example, statistics from the rfc31 are reported on a hourly basis on 9/13/1998
from 2:00 p.m. through 4:00 p.m.
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2. Complete the following fields when you use the From clause:

– Select the RF-Conductor! controller to display.

– Select either day or hour to specify how your statistics are to be grouped.

– Select from the list of dates or hours for which statistics are available. Highlight the
appropriate dates or hours

Figure 7-11: Specifying the From Clause
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Specifying the Select Clause

The Select clause specifies which statistics to retrieve, such as messages and channel usage.

1. When you press the Select tab, the Select panel appears (see Figure 7-12). This panel
displays a list of the statistics categories and statistics parameters available for your
network element.

Figure 7-12: Specifying the Select Clause

2. Highlight the statistics category to display.

3. Select the parameters for which you need statistical information.

Specifying the Where Clause

The Where clause allows you to specify conditions to display, for example, certain channels,
thresholds, or number of messages.

Select the Where tab to display the Where Clause panel (see Figure 7-13).
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Figure 7-13: Specifying the Where Clause

4. Complete the following fields:

– Select from the list of parameters that can be displayed. Select the parameter by
highlighting it in the list.

– Qualifiers are symbols you can use to limit your query:
- > indicates greater than
- >= indicates greater than or equal to
- < indicates less than
- <= selects less than or equal to
- == selects equal to values
- != specifies not equal to
- AND joins two qualifiers
- OR provides a selection

Select the qualifier from the list.

– Type a value to compare against the selected statistic parameter. Type a numerical
value.

5. When you have the proper values highlighted or typed, press the Accept button. The
new row appears in the bottom box.
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6. Continue adding to the Where clause.

7. To save your query, select the Save disk or select File > Save from the pull-down menu.

8. To run the query, you highlight the query name in the query builder and select the
Execute button (picture of a man running) or select the File > Execute menu.

9. The query results appear in chart (see Figure 7-14), bar graph (see Figure 7-15), or table
(see Figure 7-16) format after the Execute is completed. For reporting or archiving the
results, you can also print or save the results. To view the different formats, select the
view you desire from the available tabs.

To import the results to a spreadsheet, you must save the results (File>Save menu or the
Save button) then locate the results file.

Displaying Query Results

The following examples illustrate three ways of displaying results of your queries -- line
graph (see Figure 7-14), bar graph (see Figure 7-15), and table (see Figure 7-16). You can
change to the different views by selecting the appropriate tab.

Figure 7-14: Displaying Query Results in a Line Graph
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Figure 7-15: Displaying Query Results in a Bar Graph

Figure 7-16: Displaying Query Results in a Table
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Printing Query Results

You can also print the query results. Use the following instructions to print your results:

1. Select the results to be printed. This option prints the results currently on the screen.

2. Select File>Print from the pull-down menu.

The Print dialog box appears (see Figure 7-17).

Figure 7-17: Printing Query Results

3. Complete the following information in the Print dialog box:

Number of Copies:

Printer (or File)

Banner Page Title (if desired)

Print Command Options (if desired)

Paper Size

Orientation

4. Select the Print button.
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Backing Up and Restoring Folders

Using the file manager, you can back up selected folders and delete files from within a folder.
The folders are backed up to your 4mm DAT tape drive. You should back up your files each
week. After you back up the files, delete them from your active list. This backup process
maintains room for new statistical information.

Backing Up Folders

To back up folders from within the file manager, use the following steps (see Figure 7-18):

1. In the left-hand box, select the folder to be backed up.

2. With the folder selected, select the back-up icon (disk) in the toolbar or select File>Save
from the pull-down menu. The system asks you to confirm the action.

Note: Initiating a backup erases the previous contents of the tape.

3. After initiating the backup, the system informs you that the backup completed or failed.
If the backup fails, verify that you have a tape in the 4mm DAT tape drive and that the
tape is not write-protected.

If the backup is successful, the last backup column in the file display window will reflect
the timestamp of the backup.

4. You can view the contents of the tape to verify the backup by typing the following
command in a UNIX shell:

tar^tvf^/dev/rst4
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Figure 7-18: Backing Up Statistics Folders

Deleting Files

You can delete files from within the file manager by using these steps:

1. Select one or more files to be deleted in the file display window (right-hand box).

2. Select the delete icon (scissors) in the toolbar.

If you have not backed up the file, the system prompts you to confirm this deletion (see
Figure 7-19).

Note: Delete files only after you have backed them up. Files that need to be backed up will have the
words “needs backup” in the last backup column of the file display window.
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Figure 7-19: Deleting a File That is Not Backed Up

Restoring Folders

To restore folders, you must complete the following steps:

1. Exit the Historical Statistics application by selecting File>Exit from the Query Manager
pull-down menu.

2. When you have the application closed, place the tape containing the folder to be restored
in the tape drive.

3. Open a UNIX shell.

4. Type the following command to restore the tape contents:

# tar xvf /dev/rst4

5. Launch the Historical Statistics application from within HP OpenView (see paragraph,
"Set-Up Procedures").

6. Open the file manager component from the query manager by selecting Tools>File
Manager from the pull-down menu.



Choreographer!™ Network Manager Installation and Operation Historical Statistics

January 1999 6880492G07-C 7-25

7. Select the folder that you restored. You should see the restored files in the file display
window (see Figure 7-20).

Figure 7-20: Verifying File Restoration



Historical Statistics Choreographer!™ Network Manager Installation and Operation

7-26 6880492G07-C January 1999



Choreographer!™ Network Manager Installation and Operation / Appendix A

January 1999 6880492G07-C A-1

Abbreviations and Acronyms A

This appendix provides a list of abbreviations and acronyms used in this document and their
definitions (see Table A-1). These definitions are applicable only to the Choreographer!
network element and the elements of the edge network. Other applications or systems can use
the same acronyms with different meanings.

Table A-1: Acronyms and Abbreviations (Sheet 1 of 2)

Acronym/
Abbreviation

Description

CP Central Processor

DSP Digital Signal Processing

EM Element Manager

FRAD Frame Relay Access Device

FRU Field Replaceable Unit

FS File Server

FTP File Transfer Protocol

FTPD File Transfer Protocol Demon

GB Gigabyte

GPS Global Positioning System

GUI Graphical User Interface

HP Hewlett Packard

HPOV Hewlett Packard OpenView

MB Megabyte

MIB Management Information Base

MS Messaging Switch

NECA Network Element Configuration Application
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NIU Network Interface Unit

NMC Network Management Center

OMC Operations and Management Center

OTA Over the Air

OVNNM OpenView Network Node Manager

OVW OpenView Window

PA Power Amplifier

PCD Personal Communication Device

PNMS Paging Network Management System

POMC Paging Area Operations and Management Center

RAM Random Access Memory

RCP Remote Copy Protocol

RF Radio Frequency

RF-A! RF-Audience!

RF-B! RF-Baton!

RF-C! RF-Conductor!

RF-O! RF-Orchestra!

SNMP Simple Network Management Protocol

TFTP Trivial File Transfer Protocol

UCC Universal Communication Controller

UDP User Datagram Protocol

WMG Wireless Message Gateway

WMS Wireless Messaging System

Table A-1: Acronyms and Abbreviations (Sheet 2 of 2)

Acronym/
Abbreviation

Description
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Backup and Restore Procedures B

This appendix covers Choreographer! network manager backup and restore procedures. You
can back up and restore the Choreographer! network manager database with options from the
installation script, C_Install . This script may be on the hard drive or may be accessed from the
installation disk.

Backup Procedures

Database backup is a part of regular system maintenance. You should also perform a database
backup before you make any major configuration changes. This backup prevents the loss of
system configuration information. When the major changes are operational, perform another
backup to save your changes.

To back up the Choreographer! network manager database, use the following procedure:

1. Log on to the system as root.

2. If you run the backup process from the Installation CD-ROM, insert the CD-ROM into
the drive.

3. Whether you run the backup process from the installation script or from the CD-ROM,
use the following command to launch the backup process:

# cd^/opt/C_Install <Enter>

# ./setup <Enter>

The Welcome screen appears (see Figure B-1).

CAUTION

Stop all processes that affect the database, such as HP OpenView, before you begin a
backup.
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Figure B-1: Welcome Screen

4. Select the Next button to continue. The Select Components to Install menu appears
(see Figure B-2).

Figure B-2: Select Components to Install
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5. Select the Backup/Restore Data option and press the Next button. The Backup and
Restore menu appears (see Figure B-3).

Figure B-3: Backup and Restore Menu

6. Select the Backup option and press the Next button. The status screen (see Figure B-4)
appears. The system issues the RFCCTL hostname prompt:

Please enter the RFCCTL’s IP Address or Alias Hostname:
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Figure B-4: Status Screen

7. Type in the control hostname of the RF-C! controller, then press <Enter>. The tape driver
name prompt appears:

Please Enter the Tape device name (/dev/rmt/0lb)

8. When the prompt appears, the default tape driver name should already be visible. Press
<Enter> to accept the default or type [tape_driver_name] and press <Enter>.

The system prompts you to insert a tape into the tape driver:

Please put an empty tape in tape driver.

INFO: Enter ‘C’ to Continue or ‘X’ to Exit: [C]

9. Type C <Enter> to continue with the backup or X <Enter> to abort the backup process.
The system responds that the database is about to be stopped.

CAUTION

Stop all processes that affect the database, such as HP OpenView, before you begin a
backup.
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10. When the backup completes, the Installation Complete screen appears (see Figure B-5).
This screen displays the results of the backup.

Figure B-5: Installation Complete Screen

11. Select the Finish button to exit from the process. Remove the tape from the tape drive
and label the tape with the current date and time.
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Restore Procedure

If a serious system problem occurs, or you need to regress to an earlier system configuration,
use the backup tape to restore the database.

To restore the database, use the following procedure:

1. Log onto the system as root.

2. If you are running the restore process from the Installation CD-ROM, insert the CD-ROM
into the drive.

3. If you are running the restore process from the installation script resident on the hard
drive or once the CD-ROM is inserted, use the following command to launch the restore
process:

# cd^/opt/C_Install <Enter>

# ./setup <Enter>

The Welcome screen appears (see Figure B-6).

CAUTION

You must stop all processes that affect the database, such as HP OpenView, before
you begin any backup and restore procedures.
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Figure B-6: Welcome Screen

4. Select the Next button to begin.

The Select Components to Install menu appears (see Figure B-7).

Figure B-7: Select Components to Install Screen
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5. Select the Backup/Restore Data option and select the Next button to continue.

The Backup or Restore menu appears (see Figure B-8).

Figure B-8: Backup or Restore Menu

6. Select the Restore option and the Next button.

The Status screen (see Figure B-9) appears. The system prompts for the RFCCTL
hostname:

Please enter the RFCCTL’s IP Address or Alias Hostname:

7. Type [control_hostname] <Enter>.
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Figure B-9: Status Screen

8. The tape driver name prompt appears as follows:

Please Enter the Tape driver name (/dev/rmt/0lb)

9. At the tape driver name prompt, the default tape driver name should be visible. Press
<Enter> to accept the default or type [tape_driver_name] and press <Enter>. The system
displays the following prompt:

Please put a tape in tape driver.

INFO: Enter ‘C’ to Continue or ‘X’ to Exit [C]:
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10. Type C <Enter> to continue with the restore or X <Enter> to stop the restore process.

If you continue with the restore, the system warns:

Warning: About to stop the database!

11. When the restore is complete, the Installation Complete screen appears. This screen
displays the results of the restore. Select the Finish button to exit from the process.
Remove the tape from the tape driver.

Figure B-10: Installation Complete Screen

12. You must restart the RF-C! controller for the controller to use the new configuration.

CAUTION

Stop all processes that affect the database, such as HP OpenView, before you begin a
restore.
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Configuring Network Printers C

This appendix provides printer configuration procedures for the HP-4MP, the HP-5M, and the
HP-4000N. The following topics are included:

The following instructions can be used to configure an HP-4MP or an HP-5M printer as a
network printer. These configuration procedures are optional.

HP-4MP and HP-5M Laserjet Configuration

1. Push the printer power switch (front right) to ON position.

2. Verify the printer successfully completes its self test and the display panel reads:

READY

HP-4MP Configuration

1. Verify that the printer has paper (The front panel menu does not respond unless the
printer has paper in the paper tray).

2. Place printer in Off Line mode by pressing the <On Line> button on the front control
panel of the printer.

3. Press the <Menu> button until [MIO MENU] appears on the printer display.

4. Press the <Item> button until [CFG NETWORK=NO *] appears on the printer display.

5. Press the <+/-> button until [CFG NETWORK=YES] appears on the printer display.

6. Press the <Return> button until [CFG NETWORK=YES *] appears on the printer display.

7. Press the <Item> button until [TCP/IP=OFF *] appears on the printer display.

8. Press the <+/-> button until [TCP/IP=ON] appears on the printer display.
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9. Press the <Return> button until [TCP/IP=ON *] appears on the printer display.

10. Press the <Item> button until [CFG TCP/IP=NO *] appears on the printer display.

11. Press the <+/-> button until [CFG TCP/IP=YES] appears on the printer display.

12. Press the <Return> button until [CFG TCP/IP=YES *] appears on the printer display.

13. Press the <Item> button until [BOOTP=YES *] appears on the printer display.

14. Press the <+/-> button until [BOOTP=NO] appears on the printer display.

15. Press the <Return> button until [BOOTP=NO *] appears on the printer display.

16. Press the <Item> button until [IP BYTE 1=0] appears on the printer display.

17. Press the <+/-> button until [IP BYTE 1=10] appears on the printer display.

Note: Hold down the <+/-> button for automatic incrementing.

18. Press the <Return> button until [IP BYTE 1= 10*] appears on the printer display.

19. Press the <Item> button until [IP BYTE 2=0] appears on the printer display.

20. Press the <+/-> button until [IP BYTE 2=5] appears on the printer display.

Note: Hold down the <+/-> button for automatic incrementing.

21. Press the <Return> button until [IP BYTE 2=5 *] appears on the printer display.

22. Press the <Item> button until [IP BYTE 3=0] appears on the printer display.

23. Press the <+/-> button until [IP BYTE 3=0] appears on the printer display.

Note: Hold down the <+/-> button for automatic incrementing.

24.  Press the <Return> button until [IP BYTE 3=0 *] appears on the printer display.

25. Press the <Item> button until [IP BYTE 4=0] appears on the printer display.
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26. Press the <+/-> button until [IP BYTE 4=50] appears on the printer display.

Note: Hold down the <+/-> button for automatic incrementing.

27. Press the <Return> button until [IP BYTE 4=50 *] appears on the printer display.

28. Press the <On Line> button to place the printer in the On Line mode.

Local printer set up is complete for HP-4MP.

HP-5M and HP-4000N Configuration

1. Verify that the printer has paper (The front panel menu does not respond unless the
printer has paper in the paper tray).

2. Place printer in Off Line mode by pressing the <Go> button on the front control panel of
the printer.

3. For the HP-5M, press the <Menu> button until [HP MIO MENU] appears on the printer
display.

For the HP-4000N, press the <Menu> button until [JETDIRECT MENU] appears on the
printer display.

4. Press the <Item> button until [CFG NETWORK=NO *] appears on the printer display.

5. Press the <Value +/-> button until [CFG NETWORK=YES] appears on the printer
display.

6. Press the <Select> button until [CFG NETWORK=YES *] appears on the printer display.

7. Press the <Item +/-> button until [NOVELL=ON] appears on the printer display.

8. Press the <Value +/-> button until [NOVELL=OFF *] appears on the printer display.

9. Press the <Select> button.

10. Press the <Item> button until [DLC/LLL] appears on the printer display.

11. Press the <Value +/-> key to [OFF].
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12. Press the <Select> button.

13. Press the <Item> button until [TCP/IP*] appears on the printer display.

14. Toggle the <Value +/-> key to [ON].

15. Press the <Select> button.

16. Press the <Item> button until [ETALK] appears on the printer display.

17. Toggle the <Value +/-> key to [OFF].

18. Press the <Select> button.

19. Press the <Item> button until [CFG TCP/IP] appears on the printer display.

20. Toggle the <Value +/-> key to [YES].

21. Press the <Select> button.

22. Press the <Item> button until [BOOTP] appears on the printer display.

23.  Toggle the <Value +/-> key to [BOOTP=NO].

24. Press the <Item> button until [BOOTP=NO *] appears on the printer display.

25. Press the<Item> button until [IP BYTE 1=0] appears on the printer display.

26. Press the <Value +/-> button until [IP BYTE 1=10] appears on the printer display.

Note: Hold down the <+/-> button for automatic incrementing or decrementing.

27. Press the <Select> button until [IP BYTE 1=10 *] appears on the printer display.

28. Press the <Item> button until [IP BYTE 2=0] appears on the printer display.

29. Press the <Value+/- > button until [IP BYTE 2=5] appears on the printer display.

30. Press the <Select> button until [IP BYTE 2=5 *] appears on the printer display.
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31. Press the <Item> button until [IP BYTE 3=0 *]appears on the printer display.

32. Press the <Value+/- > button until [IP BYTE 3=0] appears on the printer display.

33. Press the <Select> button until [IP BYTE 3=0 *] appears on the printer display.

34. Press the <Item> button until [IP BYTE 4=0] appears on the printer display.

35. Press the <Value +/-> button until [IP BYTE 4=50] appears on the printer display.

36. Press the <Select> button until [IP BYTE 4=50 *] appears on the printer display.

37. Press the <Item> button until [SM BYTE 1] appears on the printer display.

38. Press the <Value+/-> button to increment to 255.

39. Press the <Select> button.

40. Press the <Item> button until [SM BYTE 2] appears on the printer display.

41. Press the <Value+/-> button to increment to 255.

42. Press the <Select> button.

43. Press the <Item> button until [SM BYTE 3] appears on the printer display.

44. Press the <Value+/-> button to increment to 0.

45. Press the <Select> button.

46. Press the <Item> button until [SM BYTE 4] appears on the printer display.

47. Press the <Value+/-> button to increment to 0.

48. Press the <Select> button.

49. Press the <Item> button until [LG BYTE 1] appears on the printer display.

50. Press the <Value+/-> button to increment to 10
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51. Press the <Select> button.

52. Press the <Item> button until [LG BYTE 2] appears on the printer display.

53. Press the <Value+/-> button to increment to 5

54. Press the <Select> button.

55. Press the <Item> button until [LG BYTE 3] appears on the printer display.

56. Press the <Value+/-> button to increment to 0

57. Press the <Select> button.

58. Press the <Item> button until [LG BYTE 4] appears on the printer display.

59. Press the <Value+/-> button to increment to 2

60. Press the <Select> button.

61. Press the <Item> button until [GW BYTE 1] appears on the printer display.

62. Press the <Value+/-> button to increment to 10

63. Press the <Select> button.

64. Press the <Item> button until [GW BYTE 2] appears on the printer display.

65. Press the <Value+/-> button to increment to 5

66. Press the <Select> button.

67. Press the <Item> button until [GW BYTE 3] appears on the printer display.

68. Press the <Value+/-> button to increment to 0

69. Press the <Select> button.

70. Press the <Item> button until [GW BYTE 4] appears on the printer display.
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71. Press the <Value+/-> button to increment to 2

72. Press the <Select> button.

73. Press the <Item> button until TIMEOUT appears on the printer display.

74. Press the <Value+/-> button to increment to 90.

75. Press the <Select> button.

76. Press the <Go> button to place the printer On-Line.

Local printer set up is complete for HP-5M or HP-4000N.
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